Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   New Jeep Owner (Needing Guidance!) (http://www.wranglerforum.com/f19/new-jeep-owner-needing-guidance-150215.html)

SirBuddlyLongFellow 03-31-2012 09:33 AM

New Jeep Owner (Needing Guidance!)
 
Hello, Just bought my first Wrangler (I've always wanted one, and I love having it), but it feels like it's lagging, or sputtering and that the gas isn't getting to it right away. Feels like maybe a fuel pump problem? Also, it has stalled on me while going from Reverse to Drive (backing out of driveway). Is the fuel pump the culprit? Or is it going to be much more complicated/costly than that?

Jeep is a 98' Sahara 130K miles, 6 Cyl 4.0 Liter

Also, I'm new to the 'WranglerForum' so I don't know if I'm using this correctly and if anyone can see this...? :redface:

Beastmaster 03-31-2012 02:35 PM

Sounds like the fuel pump to me but I'm not real familiar with TJs.
I'd suggest you post here: TJ Jeep Wrangler Forum - Jeep Wrangler Forum

I think you'll get more answers there.

In the mean time . . .

Welcome to the forum!

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

BT 03-31-2012 04:39 PM

Welcome to WF! :D

My YJ sputtered and idled rough for a few weeks. Even stalled on me a few times. 4.0 I6 Auto trans. My father and I did a good tune up(Plugs and wires, oil change, and a fuel system treatment.) and she has ran like champ even since! Might give that a try before replacing a part that may not need replacing. Just a thought :thumb:

SirBuddlyLongFellow 03-31-2012 06:22 PM

Quote:

Originally Posted by bta2011 (Post 2204206)
Welcome to WF! :D

My YJ sputtered and idled rough for a few weeks. Even stalled on me a few times. 4.0 I6 Auto trans. My father and I did a good tune up(Plugs and wires, oil change, and a fuel system treatment.) and she has ran like champ even since! Might give that a try before replacing a part that may not need replacing. Just a thought :thumb:

I'm new to forums in general, but this place is awesome! I love the Wrangler community! Thanks a lot guys for the advice! Now I have hope that it's not a major issue!

BT 03-31-2012 10:38 PM

To me it sounds like it just needs a tune up. If that doesn't fix it then at least you got that out of the way and then you know it's something more serious.


All times are GMT -5. The time now is 10:34 AM.