Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Engine trouble!!!! isfiring and no Power!!!HELP!!!! (http://www.wranglerforum.com/f274/engine-trouble-isfiring-and-no-power-help-150497.html)

Willy Spicolli 04-01-2012 03:23 PM

Engine trouble!!!! isfiring and no Power!!!HELP!!!!
 
OK. So, Already been having an issue with the oil burning out too fast. Switched over to 5w-30 and that has slowed down the amount that I've been having to put in. The other day I think I put in a lil too much. The engine started acting up. All of a sudden I was loosing acceleration power and it sounding like it was misfiring. Me being not mechanically inclined whatsoever thought it might have been the spark plugs(I just hit 60,000m). So those got changed out. Still had the same issue(misfiring sound and no power). After a while of stairing at my poor baby with the hood open, I figured the problem might have been that I put too much oil in it. So I completely drained it and added 5 qts. Let it run for a while AND STILL have the same issue?!?!?!? WTF... sigh... Trying to get the problem fixed ASAP since both my wife and myself work(and we don't like walking). Any takers on this issue??? Oh, and of course the engine light is on. Computer was reading a p0406 and p0300 codes before I tried to fix anything myself.

Willy Spicolli 04-01-2012 03:34 PM

Oh, and it's idling at 500 rpms instead of it's normal 750.

tazoez 04-01-2012 04:01 PM

P0406 : EGR position sensor error

P0300 : Misfire multiple cylinders.

If you are not mechanically incline, IMHO, I would bring it into the shop for repair, especially if you already changed plugs (I had a misfire #2, but new plugs made my baby happy).


All times are GMT -5. The time now is 01:30 PM.