Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   97 Tj issues (http://www.wranglerforum.com/f282/97-tj-issues-150895.html)

Nick97tj 04-03-2012 12:51 AM

97 Tj issues
 
Hello out there, I just joined and I am wondering if anyone can help me out with my problem which is I have a 97 tj with 89k miles, at random times usually on the highway above 45 mph it will lose power, chug and what sounds like a back fire but the sound is coming from under the hood like a miss firing cylinder that didnt fire with too much fuel. I thought it was a the fuel pump but the mechanic said the system was fine.....I was told it may be the ignition module, anyone else had this issue? It's the 4.0 with a jet stage1 power chip, rocket air intake and cat back exhaust......any ideas or same problem?

causestosin 11-25-2013 12:04 PM

Double check your battery cables and connections, make sure they are not corroded.

acf5 11-25-2013 12:28 PM

Make sure your air intake is actually filtering the air, many of these "cold air intakes with better airflow" get you more airflow by having less fine of a filter. Your chip may also be screwing with you, they hardly do much, I'd take it off but that's my opinion.

acf5 11-25-2013 08:31 PM

Quote:

Originally Posted by causestosin (Post 6374306)
Double check your battery cables and connections, make sure they are not corroded.

Pssst, this is a couple months old XD I just realized

ChasUGC 11-25-2013 08:41 PM

Quote:

Originally Posted by acf5 (Post 6384786)
Pssst, this is a couple months old XD I just realized

More like a 1-1/2 yrs. old. I think he fixed it by now.:lmao:


All times are GMT -5. The time now is 05:03 PM.