Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   need help now please! trying to finish! (http://www.wranglerforum.com/f282/need-help-now-please-trying-to-finish-151358.html)

tcate23-WRANGLER 04-04-2012 08:24 PM

need help now please! trying to finish!
 
hey guys, trying to put my stock skid plate back on. Should i have to jack it up to get it back on or do i have it backwards?

The bolts are going in but it looks like its raising the transmission too? How should i reinstall it?

THANK YOU, really wanna drive it tomorrow!

GoldenSahara00 04-04-2012 08:26 PM

Are your studs for tcase mount through the skid? You should have had your transmission supported at the bell housing while the skid was off. If you didn't then it probably lowered so your fine then.

tcate23-WRANGLER 04-04-2012 08:31 PM

Quote:

Originally Posted by GoldenSahara00 (Post 2220668)
Are your studs for tcase mount through the skid? You should have had your transmission supported at the bell housing while the skid was off. If you didn't then it probably lowered so your fine then.

thanks golden, yes when the skid was off it was supported by the bell housing. The 4 nuts are on but when i bolt the frame bolts in, it lifts up the transmission.

Like I had the skid on a hydraulic jack and was supported by that while i was trying to get it on. I then put the bolts in the right side frame and went to do the left and couldnt without jacking the skid up more.

GoldenSahara00 04-04-2012 08:34 PM

Quote:

Originally Posted by tcate23-WRANGLER

thanks golden, yes when the skid was off it was supported by the bell housing. The 4 nuts are on but when i bolt the frame bolts in, it lifts up the transmission.

Like I had the skid on a hydraulic jack and was supported by that while i was trying to get it on. I then put the bolts in the right side frame and went to do the left and couldnt without jacking the skid up more.

Well if your holes are lined up then it should be right. Uh I'm gona see if I have a pic of the skid so I can tell you front fro back. But as long as the holes line up and the tcase mount is through and started te bolts then you should be fine.

GoldenSahara00 04-04-2012 08:35 PM

1 Attachment(s)
The front is in the bottom of the pic. As you can see there is a slight taper.

tcate23-WRANGLER 04-04-2012 08:37 PM

Quote:

Originally Posted by GoldenSahara00 (Post 2220712)
Well if your holes are lined up then it should be right. Uh I'm gona see if I have a pic of the skid so I can tell you front fro back. But as long as the holes line up and the tcase mount is through and started te bolts then you should be fine.

thanks man and a picture would be great. You really came through for me!!

tcate23-WRANGLER 04-04-2012 08:40 PM

Quote:

Originally Posted by GoldenSahara00 (Post 2220716)
The front is in the bottom of the pic. As you can see there is a slight taper.

thank you so much man!

GoldenSahara00 04-04-2012 09:35 PM

No prob get it back on?

tcate23-WRANGLER 04-04-2012 10:36 PM

Quote:

Originally Posted by GoldenSahara00 (Post 2221053)
No prob get it back on?

yeah and test drive went good! post bl/mml, thanks again man


All times are GMT -5. The time now is 03:46 AM.