Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   just cant get it to run (http://www.wranglerforum.com/f218/just-cant-get-it-to-run-151734.html)

Mark Tice 04-06-2012 12:39 PM

just cant get it to run
 
After two months of replacing parts, tracing wires and getting nowhere i sit with a dead 90 yj in the driveway. After reading other forums i have replaced all but the computer. As it sits right now the fuel pump stays running when the key is switched to "run" fuel is making it to the tb. Any thoughts?

4Jeepn 04-06-2012 12:43 PM

4 or 6cly?

Mark Tice 04-06-2012 04:03 PM

4

4Jeepn 04-06-2012 05:08 PM

does it turn over? If so are you getting spark at the plugs? Have you tried to get any codes off it?

NHrubicon 04-06-2012 05:17 PM

I hate to say it, but I'd guess it's time to replace the computer. I had a 94 YJ, 4 cyl, rebuilt and modified, spent over $4000 just in parts...and a week after we got it back from the shop, it did exactly what yours is doing. Dead...turn over all day but nothing. Mechanic said to order a new computer-give them the VIN number or something-they ask for it-and it arrived a couple days later. Plugged it in...and as far as I know it is running still-sold it last year. When we took the old one out, when the case came off-you could see the smoke and charred contacts where it had overheated and committed suicide.

Garyk 04-06-2012 05:18 PM

If you are getting fuel and spark, the only thing left is timing and proper fuel mixture, but even if its set rich you should get a burp now and then.

Mark Tice 04-06-2012 05:18 PM

It dose fire, no codes, it dose roll over. If i pull the relay for the fuel pump the jeep will start for a few seconds b/c it's not being flooded

Garyk 04-06-2012 05:19 PM

So it floods??Sounds like a TB problem

Mark Tice 04-06-2012 05:22 PM

If i pull the cap off of the tb it will shoot fuel at you when turned to run

brentd711 04-06-2012 05:35 PM

Quote:

Originally Posted by Mark Tice (Post 2227286)
the fuel pump stays running when the key is switched to "run" fuel is making it to the tb. Any thoughts?

You must realize that the fuel pump isn't supposed to stay running with the key in "run" if it doesn't start. Has it done this for a while? Have you done something with the electrical system?

Mark Tice 04-06-2012 05:59 PM

I know it's not supposed to stay running, I have replaced corroded connections, the timing, everything dealing with ignition, the fuel pump, and reseated all of the fuses.

brentd711 04-06-2012 07:40 PM

I think the ECM controls the fuel pump in the '87-'90 and if it doesn't see a crank signal (from the CPS) in a couple of seconds it shuts the pump off. Later models have an ASD relay in the PCM. Sounds like you may have an ECM issue.

Here's a diagnostic guide for the TBI system.

Mark Tice 04-06-2012 07:58 PM

Thanks, I haven't seen a diagnostics page like this. I replaced the CPS a couple weeks ago. I agree ECU is the next purchase. Thank you all for taking the time to reply to the post.

Mark Tice 04-06-2012 07:59 PM

ECM is the next purchase... typo above

Mark Tice 04-23-2012 06:29 PM

New ecm installed and now the fuel pumps not getting power. This thing really hates me!

brentd711 04-23-2012 07:24 PM

At least it's not flooding. Have you swapped relays, checked fuses and ground wire?

Mark Tice 04-23-2012 07:33 PM

New relays, grounds are good.

Mark Tice 04-23-2012 07:33 PM

What fuse? I cant find one that is bad

Mark Tice 04-24-2012 08:49 AM

Would there be anything on the throttle body that would cause the symptoms?

brentd711 04-24-2012 01:07 PM

There's a wide open throttle switch that's supposed to cut off fuel supply when you put the pedal to the floor (when it's flooded). It's a white plastic thingie with a microswitch on the throttle cable bracket at the TB. You can try disconnecting it and see if that's the issue.

Mark Tice 04-24-2012 01:21 PM

I'll look for it.

DieLawn19k 04-24-2012 01:27 PM

Ouch, sounds like you bought my old Jeep, it isn't a red jeep with a lift is it? The only way that piece would run was if I unplugged the alternator. Good luck man, I definitely feel your pain.

Mark Tice 04-24-2012 01:49 PM

Thanks, I've gotten used to the disappointment the last few months. Im learning alot, but cant seem to catch the "ghost"

DieLawn19k 04-24-2012 01:54 PM

I hear ya, I gave up on mine after dumping money into it for 6 months, sold it for a grand, and just bought a '93 grand cherokee to last me until basic. Got a wrangler again now though thank god.

brentd711 04-24-2012 01:57 PM

Mark, if you haven't already you should try putting 12V to the fuel pump just to make sure it isn't a dead pump.

Mark Tice 04-24-2012 02:02 PM

Thanks i have. I even replaced it a month ago. With no success i dropped the tank once more and verified the pump once more. After i installed the refurbished computer yesterday its not getting voltage at the pump (checked with s meter).

Mark Tice 04-24-2012 05:07 PM

Disconnected the wide open switch and still no voltage back by the pump. I checked, 3 legs on the relay have 12v when key is turned to "run".?????

brentd711 04-24-2012 09:19 PM

12V off the relay but nothing at the harness for the pump? Did you use harness ground or good clean metal ground point on the frame?

It would be a real fluke but is it possible the ECM connector isn't quite right...may be worthwhile to unplug the harness at the ECM and reconnect it if that's all you've changed since the pump last ran.

Mark Tice 04-25-2012 09:47 AM

I scrubbed the ground clean and replaced the crimp on connection. Ill retry the connector this afternoon.

brentd711 04-25-2012 10:03 AM

If you think you got a bad ECM let me know, I've got one from a '90 2.5L 5-spd.


All times are GMT -5. The time now is 01:59 PM.