Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Ticking behind dash (http://www.wranglerforum.com/f282/ticking-behind-dash-152394.html)

rdock31 04-09-2012 04:01 PM

Ticking behind dash
 
Lately I've been noticing a ticking noise behind my dash, coming from the center from what I can tell. :confused: It only does it while stopped in gear idling (Ex. At stop lights) and doesn't do it any other times. Anybody know of a fix, or anyone else with this? Thanks.

Ryan

zimi117 04-09-2012 04:13 PM

Have it with my current 98" wrangler and 96xj. Must be a jeep thing. Only fix I found was to blast Floyd louder :punk:

Wesboy 04-09-2012 07:23 PM

Could be the relay for the indicators.
My hazards and indicators were working fine but the relay was randomly ticking.
This occured after a very over-zealous high pressure wash under the flares so I assume water in the indicators was causing it.
The relay ticking slowed down, became less random and eventually stopped.

commodore_dude 04-10-2012 09:52 AM

You sure it's not the a/c compressor?

cubalz 04-10-2012 10:11 AM

Quote:

Originally Posted by commodore_dude (Post 2240705)
You sure it's not the a/c compressor?

This would be my guess too. Do you hear it when have the heat on?

jeepins 04-10-2012 10:23 AM

I had a sort of ticking on mine coming from behind the dash. Drove me absolutely nuts for months. I tore the whole dash apart - nothing. One day I lifted the hood and leaned over on the driver's side support bar that runs from the firewall to the grille. It made the same noise. I noticed the metal around the bolt on the firewall had a gash in it (probably from hitting a full size tire/rim on the freeway doing 75 awhile back). Anyway, I just loosened the bolt on the grille and then tightened it again and it's quiet now.

Not sure this is your issue but that's where mine came from.

GoldenSahara00 04-10-2012 10:23 AM

Quote:

Originally Posted by Wesboy
Could be the relay for the indicators.
My hazards and indicators were working fine but the relay was randomly ticking.
This occured after a very over-zealous high pressure wash under the flares so I assume water in the indicators was causing it.
The relay ticking slowed down, became less random and eventually stopped.

X2 same here.

rdock31 04-10-2012 01:12 PM

Thanks a lot guys, but it does it when AC/Heat is off, haven't tried it with it on. I'll check that out when I get a chance. And it only does it in Drive, not in reverse neutral or park. Also if it makes any difference only does it when the steering wheel is straight or slightly turned, the noise goes away when I actually turn the wheel.

rdock31 04-13-2012 07:52 PM

Here's a clip of the noise and let me know what you think

Click behind dash 99 TJ Sport - YouTube

thanks,

Ryan

Wesboy 04-13-2012 08:14 PM

Quote:

Originally Posted by rdock31 (Post 2255590)
Here's a clip of the noise and let me know what you think

Click behind dash 99 TJ Sport - YouTube

thanks,

Ryan

Definately NOT the relay for the indicators.

rdock31 04-13-2012 08:18 PM

haha any idea of what it could be then?


All times are GMT -5. The time now is 07:17 PM.