Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Burning smell after a little mudding (http://www.wranglerforum.com/f274/burning-smell-after-a-little-mudding-152754.html)

colton.higgins 04-10-2012 09:52 PM

Burning smell after a little mudding
 
So me and my brother went mudding yesterday, got stuck and had to be winched out by another jeep, and now all I can smell when I drive is sort of a burning clutch smell. I washed underneath 3 times and got all the mud off the undercarriage and wheels. Its a 2012 with only 4000 km on. It also feels a little shaky while starting off in first gear since then. What could this be? I know I was a bit hard on my clutch trying to get unstuck.

Cheers!

Casotakar1229 04-10-2012 10:08 PM

welcome to wf. :thumb:

when I run the clutch really hard and even when I go wot for that matter, I get a "burning smell" and some nice exhaust fumes. sounds normal to me...but surprised you never smelled it before. fairly new engine you got there too...

ESP 04-10-2012 10:47 PM

A little mud doesn't get you stuck. I don't think we are getting the full story here. You need to really clean every inch of your jeep. If you had both axles submerged under water/mud then check your breathers to make sure they are still connected and no liquid entered.

Did you use your clutch while in the mud? If so, you've let in a lot of garbage into your tranny.

colton.higgins 04-11-2012 10:28 PM

I wasn't at all submerged in water or mud. My drivers side wheels weren't even stuck it was just my passenger side. It was just really heavy mud, no water at all. I did ride the clutch really hard trying to get untuck. Underneath wasn't even that muddy, mostly just stuck to the skid plates. I couldn't spin my wheels to get mud everywhere. All the mud was mostly on the wheels. So I'm confused on why it still stinks. I'm new to four wheeling, don't know a lot about it and what to do in some situations.

MarineHawk 04-12-2012 12:06 AM

Quote:

Originally Posted by ESP (Post 2244258)
...Did you use your clutch while in the mud? If so, you've let in a lot of garbage into your tranny.

I'm starting to like the fact that I have an auto trans with raised breathers.

WatchThis! 04-12-2012 12:18 AM

Did you remember to turn your traction control off if you were in high range? That could be why you had to be hard on your clutch.

rics1997 04-12-2012 02:48 AM

If you change gears in high mud, you can get mud between the clutch causing issues. Never use the clutch in high water or mud

joe buell 04-12-2012 05:26 AM

for what its worth the first time i had my 12 jk in the mud got a real bad clutch burning smell and mine is a auto i was realy giving it hell buried it to the frame only 3k on it assumed smell was from exhaust/ maybe cat converter smell went away after a couple miles on the way home was realy worried but norm i guess

OH9JK 04-12-2012 07:09 AM

Ahhh the smell of burning clutch and mud....in all seriousness make sure you hose off real good. Mud likes to get into everything and causes all sorts of crazy issues. Most likely you have some leftover mud sitting on top of your cats or muffler.

colton.higgins 04-12-2012 08:05 AM

Yeah I never changed gears at all. And I was in 4hi and forgot about traction control, whoops. After reading up about it, turns out 4lo is a pretty useful tool eh, wish I woulda know that at the time. I even had it checked out in the shop yesterday and they said everythings fine so ill just hope the smell goes away I guess. I'm probably just worrying to much lol.

Billabong73 07-17-2012 10:07 AM

I have the same clutch smell and stutter at 1st gear take off. But mine was after some sand action. I also forgot to turn of the traction control. :( I hate that button! I did give the under carriage a good "hows ya father" when I got home.

Only 2K on my '12 JKU, going to bring it to dealer, hopefully they will replace clutch (it is warrantied to 12K miles).

JEEP425 04-03-2013 05:27 PM

Same thing happened to me when driving my '12 JKU Manual... I think it was just mud on the exhaust because it went away with in a mile or 2 down the road.


All times are GMT -5. The time now is 08:44 PM.