Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Dome Lights Won't Shut Off? (http://www.wranglerforum.com/f274/dome-lights-wont-shut-off-153147.html)

RRTRI 04-12-2012 04:55 PM

Dome Lights Won't Shut Off?
 
1 Attachment(s)
Hi all,

I've been lurking here for about a month reading all of the great posts but this is my first one. I searched and wasn't able to find an answer to my question so I'm throwing it out there to see if anyone can safe me a 40 minute drive to the dealer.

My wife and I have had 2 Jeeps since we've been together (93 wrangler, 00 Cherokee) and as we've been approaching that mid life point my wife began asking for a new wrangler for herself. I was against the idea but finally broke down and bought her a new one about a month ago. Long story short she is ticked off at me 70% of the time because I'm driving it every chance I get. :) Now the wheels are turning about us being a two wrangler family as I've fallen in love with it.

Anyway...getting to the point of my question....

The model is a 2012 JKU Sport (Manual Trans, 2 1/2 lift, 35's, various other accessories)

We aren't sure how long it has been like this (not long we think but we can't be sure) but the dome lights will not turn off. Doesn't matter if you are driving (night or day) they are on 100% of the time. We checked the steering wheel stalk and it isn't on, we checked all the door connectors and they all seem fine, and we pushed the dome buttons themselves all with no success in getting them to turn off.

We've had a the dealer do a fair amount of work to since we've had it. They did the lift, tires, etc. They also did some electrical work (hitch, light bar across the grill). What we are questioning is have we had the problem since they did the electrical work? We believe the answer is no as we've driven it at night since it having been done 3 weeks ago, and surely would have noticed it before a couple of days ago when we first noticed it.

I called the dealer to see if there was something obvious we missed and they didn't have anything and said to bring it in. Given that they are 40 minutes away I'm hoping someone might have an easy answer other than take the bulbs out.

I know everyone likes pictures (including me) and I only have one I took with my phone a few days after it we got it but here it is. She has a few things on order from Quadratec (including seat covers) and a set of the surprise straps we saw on here. As soon we get all that installed I will post some better pics to share the mods we've/she's done.

Thanks in advance and looking forward to hanging out on here.

JIMBOX 04-12-2012 05:32 PM

:whistling: All doors are FULLY CLOSED and the stalk DIMMER RING is all the way clockwise ??

Other than that--can't help-

:dance::rofl: JIMBO

RRTRI 04-12-2012 05:36 PM

Quote:

Originally Posted by JIMBOX (Post 2251395)
:whistling: All doors are FULLY CLOSED and the stalk DIMMER RING is all the way clockwise ??

Other than that--can't help-

:dance::rofl: JIMBO

Thanks for the response...tried all that....might end up having to take it to the dealer after all!

JIMBOX 04-12-2012 05:41 PM

:D RATS, stupid dome light-


Quote:

Originally Posted by RRTRI (Post 2251411)
Thanks for the response...tried all that....might end up having to take it to the dealer after all!

Good luck-

:dance::rofl: JIMBO

kbwwolf 04-12-2012 05:54 PM

Just out of curiosity...have you tried unplugging the door plugs, like you would before removing the doors?

On newer model JK's that should disable the interior lights. I don't expect that to solve your problem, but wonder if the light would go out.

Plus, it can't hurt to exhaust all options before having to endure an annoying 40-mile trek to the dealer.

Jeep looks nice, btw. :thumb:

rics1997 04-12-2012 06:03 PM

Could try disconnecting the door harness to see if one of the doors has a bad switch

RRTRI 04-12-2012 07:52 PM

Thanks for the idea of disconnecting the door harness. I will give that a try in the morning and see if it works. Like you said if nothing else it may at least pinpoint the issue.

Thanks again

RRTRI 04-20-2012 01:18 PM

I just wanted to follow up on this thread in case anyone else runs into this issue.

After the dealer having the Jeep for over a week they called this morning and said it was finally ready to be picked up. Through out the last week they tried many different things with zero resolve. Among things they tried was replacing light stalk, some lighting module, checking the wiring on the light bar, and ordered a new instrument cluster.

When we went to pick it up a bit ago I had assumed it must have been the instrument cluster. When we got there I asked about it and the service advisor told me he'd show me.

Turns out that it was my fault! I had installed one of those Hi-Lift Sport Cages and cut a wire with the passenger side clamp! I didn't even know it was there and the dealership never thought about it either until today. Anyway...they repaired it and it is working like a champ now!

Thanks for all the input!

ESP 04-20-2012 01:35 PM

^ :facepalm:

x2 on the recommendations for removing the wiring harness. You don't have a light when you get in but it's not big deal and you never have to worry about your passengers hitting their heads on the light buttons switches and not telling you the lights are on until you find them the next day. Ask me how I know this. :whistling:


All times are GMT -5. The time now is 08:09 AM.