Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Speedo/engin light after procal module connected (http://www.wranglerforum.com/f274/speedo-engin-light-after-procal-module-connected-155037.html)

Vampire3333 04-21-2012 12:09 PM

Speedo/engin light after procal module connected
 
My speedometer stopped working and my engin light came on and my clock reset after doing my tire size and air pressure reset with the aev procal module did this happen to any one else what should I do? I called aev they have not called me back.

kbwwolf 04-21-2012 01:28 PM

They've got their own blog on their site, w/a FAQ and troubleshooting section. You can check that out, see if there's a fix for your problem.

Also, sometimes if you reset the procal, then try the changes again on your Jeep, they'll take. I had that happen when centering my steering wheel...signals weren't lighting to tell me which way I needed to adjust. Unplugged it, reset the dip switches, plugged it back in and all was well.

You may end up having to talk to someone @ AEV, though. Every now and then one of the units has a glitch that can only be fixed by a pro.

ESP 04-21-2012 01:35 PM

^ Bam!

Baby Huey 04-21-2012 01:37 PM

Me Too ,Meeeee Too..... I just did the same thing on my JKU X , I measured the tires, did the math and adjusted the dip switches , turned the ign. on, plugged it the ProCal and the horn honked. I smiled a big smile, proud of myself.... I unplugged the Procal shut off the ign switch, got, shut the door.
Went to get back in to move the Jeep out of the shop and the Door was locked, luckly I had the keys, got back in, tried to start and NOTHIN....just clicks, all the lights light up on the dash.
I wrote down a post from here about resetting the Computer, so I came in to get it, and read this post.
Sure hope somebody is there on Saturdays.... LOL
Good luck on yours Vampire !!...... BH

Baby Huey 04-21-2012 02:11 PM

Sorry I jumped into your Thread Vampire !!
I hooked up the Battery Charger and charged for about 20 minutes and it fired right up.
Hasn't ran in over two weeks . So I guess Huey buys a battery !!
Thanks Guys !! "BH"

Vampire3333 04-21-2012 08:15 PM

Thanks guys, no sweat Huey...

Vampire3333 04-28-2012 09:27 PM

My mechanic Hooked the jeep up to a scanner of some sort and fixed everything !!!! $20 lol he is a good friend so I'm not sure of a real price.
Thanks again everyone


All times are GMT -5. The time now is 01:47 AM.