Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   CJ General Discussion Forum (http://www.wranglerforum.com/f298/)
-   -   1980 CJ-5 won't start (http://www.wranglerforum.com/f298/1980-cj-5-wont-start-160560.html)

shaneharrelson93 05-16-2012 05:37 AM

1980 CJ-5 won't start
 
my cj5 stalled one day while i was heading home. It has spark to the coil and plugs. When i pump the gas pedal gas sprays into the carb. It has a brand new ignition control module. I am at a lose. It will turn over but it doesnt fire or sound like its going to start. Any help!!!

1959elcamino 05-18-2012 08:24 AM

try taking off a valve cover.you could have a broken cam

shaneharrelson93 05-18-2012 01:15 PM

I have a 304 v-8

sevenservices 05-18-2012 01:19 PM

Engine needs three things to run. Fuel, Compression and Spark.

You have fuel,
You have spark,
either you are loosing compression or sparking at the wrong time.

shaneharrelson93 05-18-2012 07:01 PM

I am taking the timing chain cover off to see if it jumped timing.

4Jeepn 05-18-2012 07:33 PM

could also be a loose vacuum line. I forgot to put one on good and tight on my cj after doing the valve cover replacement. Caused all kind of starting issues.

Rusty jeep 05-18-2012 09:41 PM

Check your distributor gear. The 304 and the 360 are bad about the cam walking toward the front of the motor. When that happens it sheers the gear on the cam and the dist. my 360 did just that. Ran fine then nothing. Just what your describing.

Cj7otr 05-18-2012 11:42 PM

Careful taking off the timing chain cover. You'll need to re-prime the oil pump. AMC made it a little difficult to check on the timing chain.

shaneharrelson93 05-19-2012 06:27 AM

Thanks for all the replies. I will keep posted


All times are GMT -5. The time now is 09:02 AM.