Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   HELP After Engine stall underwater!!! (http://www.wranglerforum.com/f19/help-after-engine-stall-underwater-163146.html)

Moody715 05-28-2012 10:48 PM

HELP After Engine stall underwater!!!
 
I was off roading today and driving across a water crossing. Lots of water flooded the engine and I was about hood deep in water. Stayed there for about 10 min till someone could get to me to pull me out.

I was pulled out and first thing was took out the spark plugs and dried them then shot the water out of the engine (as much as possible)

I then changed my oil first thing. It came out a chocolate milky color and knew there was water.

What are all the major and tiny things I need to check immediately to make sure I do not break anything or have anything go bad.

Also since then my oil pressure runs higher than usual and then drops like crazy when in neutral. While driving. Can my oil pump be clogged or tubes be clogged? It was river water and sand was sitting in the bottom floorboards after so I assume that's what is in the engine...
NEED HELP!! THANKS

tj00wrangler 05-29-2012 12:00 AM

You could change your oil and filter again to make sure all water and sand came out. Since you where hood deep you'll wanna change all fluids. Diff, tranny and transfer case. Good chance that all your breather tubes went under water.

1jeeplvr 05-29-2012 08:54 PM

Id def get that oil changed ASAP.

willee51 05-30-2012 05:49 AM

Why do you young folks insist on using your Jeep as a "submarine" :nonono: It's been proven on this Forum, that in the end, the cost ($$$) will be subsantial :whistling:

Moody715 05-30-2012 10:16 PM

Thanks for the help. She's up and running great as usual.

Went ahead and personally changed both diffs (front full of water) and cleaned and maintinanced them. Changed the oil (full of water) immediately after got out of water and again yesterday with new filter.

Had transmission flushed today with extra fluid (2.5 extra quarts) run through it.

Runs just like before and no problems so far!!

tj00wrangler 05-30-2012 11:41 PM

Did you check the air filter?

kjeeper10 05-31-2012 06:56 AM

http://www.offroaders.com/info/tech-...r-crossing.htm

Moody715 05-31-2012 07:11 PM

Yeah went ahead and replaced the air filter too. Pretty much changed out and cleaned everything i could

Moody715 05-31-2012 07:11 PM

Quote:

Originally Posted by kjeeper10

Thanks for the link


All times are GMT -5. The time now is 01:55 AM.