Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   Poor Gas Mileage and Performance (http://www.wranglerforum.com/f19/poor-gas-mileage-and-performance-163370.html)

kcrfire30 05-29-2012 10:35 PM

Poor Gas Mileage and Performance
 
I have a 2004 Jeep Wrangler X 4.0 with 42,000 miles. I am getting 7 miles to the gallon and cannot exceed over 60 mph on the hwy. I have replaced the following in the last year: new oil pump, oil pump gauge sensor, new spark plugs, new catalytic converters front and along the exhaust pipe, new throttle position sensor, new O2 sensors (all 4), new thermostat, new pcp elbows, and new air filter. It all started with oil gauge peg to L. My buddy thought it was the oil pump and put on a new one. No change. I then put on a new oil pump gauge sensor. That took care of that. Then I continued to hear a rattle coming from the driver side in the engine compartment. I then changed the spark plugs, air filter, front driver side wheel bearings, brakes, pcp elbows, and thermostat. Still had a rattle. Took it to a muffler shop, replaced the catalytic converter on the exhaust pipe and he cut open the converter in the engine compartment. He took out the broken pieces. That worked. I Then got a cylinder 4 misfire. Replaced the spark plug. I then drove 900 miles with no CEL however only got 14 mph with A/C off. The next day CEL P0432 Catalyst behold threshold Bank 2 came on took it in to muffler shop and changed out the catalytic converter under the hood and all 4 O2 sensors. No CEL and still no power and poor fuel. I took it to the dealer today and had the distrubtor checked and was off 21 degrees. Left dealer with more power until I tried to climb above 60 MPH and could not. I got 7 mpGallon. I am schedule to take it back in tommorrow. Can someone Help me figure this out. Thank You.


All times are GMT -5. The time now is 04:03 AM.