Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   CJ General Discussion Forum (http://www.wranglerforum.com/f298/)
-   -   Cranks but no spark (http://www.wranglerforum.com/f298/cranks-but-no-spark-165532.html)

Dch47178 06-08-2012 11:28 PM

Cranks but no spark
 
I have an 84 cj7 with the 258 and an auto transmission. There was a mopar fuel injection kit on it when I bought it.
Here's my problem. The jeep died on me last weekend, I am stuck as to what to do next. I have discovered there is no spark. It gets power to ignition coil but not after it. I think it's the powertrain control module from the mopar kit causing problems but I don't know. Could this be it? And where can I get a replacement if that's thats the issue?

somike 06-09-2012 01:31 PM

Be sure to check the harness to the distributor. My 85 had to be towed home & the next morn. I found a wire disconnected. It restarted instantly after reconnecting the wire.

Dch47178 06-09-2012 05:54 PM

Thanks I'll take a look at that.

lonniedean2716 06-10-2012 09:54 PM

I have a 95 yj 4 cyl I also lost spark. Just died going down the road? I have replaced fuses,coil pack,distributor and rotor,cap,crankshaft position sensor,Ignition switch. Still nothing? Guess its the computer?

Dch47178 06-10-2012 11:31 PM

I figured it out today I had a shorted out ignition wire that caused a fuse to blow. Pray it's not the CPU when I thought it was mine I had 0 luck finding any replacement CPUs that didn't cost a bundle.

lonniedean2716 06-10-2012 11:57 PM

Do you know where the wire went that was shorted out? Was it on the harness?

Dch47178 06-11-2012 12:07 PM

It actually ran to an auxiliary fuse box the PO had installed.


All times are GMT -5. The time now is 04:23 AM.