Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Hub/Bearing Assembly (http://www.wranglerforum.com/f282/hub-bearing-assembly-167588.html)

Pilgrim_Jeep 06-18-2012 11:10 AM

Hub/Bearing Assembly
 
Just want to vent...my apologies if you read this thread looking for good advice or thought I was looking for help.

My bearing was bad. Thought it was the right front, but jacked up both sides with the tires on to check for play, and it was definitely the driver's side.

I read a few "how-to" posts, and it looked really easy.

Took the tire off, removed the caliper, removed the rotor.

Next, went to remove the cotter pin....took me 45 minutes of spraying it with PB Blaster, working it with pliers, a screwdriver, and eventually a hammer, to get it out.

Got to the axle nut. I thought I had every socket I would ever need, but did not have the 36mm required. Had to wait until the next morning to go buy one.

Went to 3 stores until I found one.

Back to the Jeep, and my 24-inch breaker bar would not do it.

Off to Home Depot to buy a 3-foot section of steel pipe.

The nut came off, grudgingly.

Took the three 13mm 12-point bolts off without incident.

Sprayed the assembly good with PB Blaster at every step of the way.

Tried to pull and pry it off...nothing. Tried hammering a screwdriver behind it. Nothing.

Kept spraying it with PB Blaster. Kept trying to work it. Nothing.

Next morning, went to Advanced Auto bright and early to rent a hub puller.

The hub puller did what it was supposed to...it pulled the hub out of the assembly. The back part of the unit did not budge.

Work on it with PB Blaster, a chisel, a hammer, a screwdriver, a torch, a prybar...worked on it until my arms couldn't move.

Took a couple of hours to run errands and recover.

Came back with the torch, chisel, and screwdriver. Chiseled of my dust shield to get a better approach angle.

Finally, after another two hours, it started to break free. Worked another side of it, and after an hour, the second side started to separate.

Another half hour on the bottom side, and it was off.

Cleaned all the surfaces really well, and bolted in the new unit, got everything put back together, and it drives like a new Jeep.

Driving to work this morning, remembered I don't have a dust shield now.

Will this have any negative effect???? Really don't want to go and undo all my work.

Cons_Table 06-18-2012 11:44 AM

Just for future reference...check this out. May have saved you quite the headache :wavey:

Unit Bearing - 1

Pilgrim_Jeep 06-18-2012 01:02 PM

Yeah, that definitely would have helped!

carlosprite 06-18-2012 02:31 PM

The little black plastic ring? It's only there to keep rocks out, does a crap job of keeping mud/sand etc out. so it's up to you really.

Now that you have taken it off , it will come off easily if you choose to put it back on.

Alternatively, buy some axle tube seals by ten factory/alloyusa/rugged ridge etc

Imped 06-18-2012 03:18 PM

Don't worry about the dust shield man....just throw it back on if you feel like it.

And FYI, I hope you lightly sanded down and cleaned the bearing surface on the knuckle and applied a light layer of grease to the outer surface of the bearing assembly. It'll make that a non-issue in the future.

Pilgrim_Jeep 06-18-2012 04:04 PM

Yep...first thing I did...cleaned out the knuckle of debris and rust, and greased the new assembly before sliding it in...definitely don't want to deal with that again.

My neighbor used to be a Jeep mechanic, and came over as i was cleaning up after the test ride....told me I should start PB Blasting the other side now, so by the time the bearing goes, I'll be ready.

Imped 06-18-2012 04:07 PM

He was a mechanic and he recommended PB? I wouldn't waste your time, considering PB is about as good as water. Check out Kroil.....hell, ATF will do a better job than PB.


All times are GMT -5. The time now is 02:36 PM.