Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   cooling SBC in 92 yj (http://www.wranglerforum.com/f218/cooling-sbc-in-92-yj-169561.html)

woodtic 06-26-2012 04:15 PM

cooling SBC in 92 yj
 
mild build on 350,aluminum radiator 6 blade steel fan/shroud,50/50 mix of anti freeze-3&3/4 gallons in system.new water pump. On road 180*F . on trail or stop &go traffic temp climbs to 210-220. looking for suggestions on practical remedy. Thanks

Ibuildembig 06-26-2012 04:16 PM

what size tstat do you have?

flatline 06-26-2012 04:19 PM

vent the hood. but I might look for actual cause. air flow? did you remove the shroud?

woodtic 06-26-2012 04:20 PM

Thermostat is 165*F

87yjman 06-26-2012 04:23 PM

stock radiator? i know its not big enough. are you using it?

87yjman 06-26-2012 04:24 PM

and in traffic but not on load sounds like an airflow problem also. big winch in front of radiator?

Ibuildembig 06-26-2012 04:26 PM

swap out the tstat for a 180-185 and it should fix it

Timberwolf 06-26-2012 11:21 PM

switch to an electric fan

loganInaYj 06-27-2012 01:35 PM

Can you post a picture of your radiator and shroud, fan etc

woodtic 06-28-2012 01:36 AM

1 Attachment(s)
http://img_0969picture of fan , radiator & shroud . I replaced 165*F tstat with a 180*F tstat. still can't let idle or it will get hot.

Ibuildembig 06-28-2012 07:59 AM

How new is the motor? Is your timing right?

woodtic 06-28-2012 08:27 AM

131 miles on new build. timing is 14* before, total is 34* with vac adv. disconected

Ibuildembig 06-28-2012 10:47 AM

Man I dunno why it's getting hot unless it has air in it somehow. I've run huge motors in yjs and never had a cooling issue.

woodtic 06-30-2012 11:03 AM

do you know what the fluid capacity of the radiators were ? Just trying to get some form of comparison

Ibuildembig 06-30-2012 12:25 PM

Capacity I don't remember but the were a 2 1inch row aluminum. I bought a 4 row one this time just for extra insurance.

woodtic 06-30-2012 03:57 PM

Thought I had the issue solved! I moved the fan 1" closer to the radiator , That did make an air flow increase & I could let it idle for 15 min. But it did slowly creep to the 210* mark. down the road I went to cool it down.Getting closer I guess.

woodtic 07-01-2012 11:03 PM

Can anyone recomend a good choice of electric pusher fan ? Hot day today- bad driving experience. NEED to get cool...

Danielross1005 05-05-2014 01:00 AM

Woodtic,
Did you ever resolve your cooling issue? I'm running a 383 stroker in a 87 yj having cooling issues here in Arizona. Running a 180 t stat, 3 row alum radiator. Alum shroud with an electric fan. Will get up to 210 with no problems. And it's only 90 out right now. If we run the ac, it will heat up even worse. Been banging my head. Can't seem to find a solution. Help would be great. Thanks.


All times are GMT -5. The time now is 05:52 AM.