Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   AEV Lift Kit - Weird Rubbing sound (http://www.wranglerforum.com/f274/aev-lift-kit-weird-rubbing-sound-170484.html)

psywash 06-30-2012 10:56 PM

AEV Lift Kit - Weird Rubbing sound
 
Hey Everyone,

I just got a 3.5" AEV lift installed on my 2012 JK. Other then the lift, the Jeep is a completely stock JK Unlimited Rubicon (Manual). I'm running it on stock wheels for now until my wheels get shipped.

I've noticed that most of the time, when I start moving, there is a brief rubbing sound coming from the rear end. It makes a subtle grinding noise then goes away and I won't be able to hear it until I stop and go again.

I want to know if anyone has any insight on this before I take it in. Has anyone had a similar issue?

Thanks,

P.

kjeeper10 06-30-2012 10:58 PM

Wheels rubbing the rear sway links ?

That's the reason for less BS'd wheels.

cavejeep 06-30-2012 11:16 PM

Quote:

Originally Posted by kjeeper10 (Post 2532914)
Wheels rubbing the rear sway links ?

x2

If so, you can flip the links to the inside of the brackets. See step 19 in the instructions on page 11... "NOTE: If the end links contact the wheel you must reverse the position of the end links so that they are on the inboard side of the stabilizer bar ends and axle tab as shown in figure 20-2".
http://www.aev-conversions.com/ishee...ensions%29.pdf

ealive 07-01-2012 10:54 AM

Quote:

Originally Posted by kjeeper10
Wheels rubbing the rear sway links ?

That's the reason for less BS'd wheels.

Yup, thats my first thought.

kjeeper10 07-01-2012 11:05 AM

Hey Psywash you figure it out?

j.luis 07-01-2012 03:28 PM

Quote:

Originally Posted by cavejeep (Post 2532956)
x2

If so, you can flip the links to the inside of the brackets. See step 19 in the instructions on page 11... "NOTE: If the end links contact the wheel you must reverse the position of the end links so that they are on the inboard side of the stabilizer bar ends and axle tab as shown in figure 20-2".
http://www.aev-conversions.com/ishee...ensions%29.pdf

X2

I had to flip the sway bar links, actually my buddy who help me install the lift did... OEM wheels do not have the backspacing to required to clear the wheel from rubbing.
The AEV 3.5 requires that you move the front sway bar link to the back. The front link is longer than the rear link you replace and that is what causes the rubbing on the OEM wheels.
Your installer should have known.

kjeeper10 07-01-2012 04:23 PM

Quote:

Originally Posted by j.luis

X2

I had to flip the sway bar links, actually my buddy who help me install the lift did... OEM wheels do not have the backspacing to required to clear the wheel from rubbing.
The AEV 3.5 requires that you move the front sway bar link to the back. The front link is longer than the rear link you replace and that is what causes the rubbing on the OEM wheels.
Your installer should have known.

Don't you have that backwards. Rear links move to the front or replaced with quick disco's and the kit provides new longer rears

psywash 07-01-2012 05:46 PM

Quote:

Originally Posted by kjeeper10 (Post 2534703)
Don't you have that backwards. Rear links move to the front or replaced with quick disco's and the kit provides new longer rears

I'll take a look when i get it in the shop on tuesday. If It is the rear links to the front, why wouldn't AEV mention that...?
Will I have to switch it back again once I get my M/T wheels?

If I shift into first and let off really really slow, it won't make the grinding noise. Then again, on different incline of roads gives me different results.

It's tough to pin-point unless I get a camera under there while I'm driving.

kjeeper10 07-01-2012 06:39 PM

Quote:

Originally Posted by psywash

I'll take a look when i get it in the shop on tuesday. If It is the rear links to the front, why wouldn't AEV mention that...?
Will I have to switch it back again once I get my M/T wheels?

If I shift into first and let off really really slow, it won't make the grinding noise. Then again, on different incline of roads gives me different results.

It's tough to pin-point unless I get a camera under there while I'm driving.

You will be able to see if the away bar link is hitting the wheel. Look for contact.

I don't know what AEV does with their lift
My Teraflex supplied new rears and the stocks moved to the front. I have heard of folks flipping the links to run the stock wheels.

ealive 07-01-2012 10:38 PM

Not sure which lift you got, but a quick glance at their cheapest 3.5 kit and it comes with rear links. So you would then move the stock rears to the front if our thinking is correct. You move the rears to the front because with your lift the fronts are now too short. You likely have a relocation bracket for the fronts (my AEV2.5" does), but probably still have to swap them for the rears. All of this will be in the install instructions which you can download for free from their site or QT. AEV is big on re-using stock components where you can.

And you don't need a camera if it is indeed the rear links making contact. Just bend over and look at the back of your rear wheels. You should be able to tell easily if contact is being made, if indeed that is the issue.

Keep us posted!

ealive 07-01-2012 10:58 PM

K so I'm bored and checked the install sheet for the 3.5" lift. You do indeed re-use the rear links, swapping them out for the front. There is also a relocation bracket for the front, but again you're now subbing the rears with the lift.

j.luis 07-03-2012 07:55 AM

Quote:

Originally Posted by kjeeper10 (Post 2534703)
Don't you have that backwards. Rear links move to the front or replaced with quick disco's and the kit provides new longer rears

You are absolutely correct, my bad... OEM front sway bar links are tiny.

MichiganJeepster 07-03-2012 07:15 PM

It could possibly be your now empty wallet rubbing together in your pocket after paying for that AEV lift. Great lift just over priced.

psywash 07-23-2012 12:43 PM

Noob mistake.
I had it running on stock wheels on. Put the new wheels on and its all smooth.
Still need to change the DS eventually.


All times are GMT -5. The time now is 01:50 PM.