Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   after changing car battery radio won't work (http://www.wranglerforum.com/f40/after-changing-car-battery-radio-wont-work-170704.html)

zagu 07-02-2012 12:22 AM

after changing car battery radio won't work
 
Since my stock battery gave out on me i had no choice but to change. After changing everything seems well except for the radio headunit. It wont turn on. Any idea? Thanks

bbtj 07-02-2012 07:34 AM

check the fuses is the only thing I can think of.

jefferyfghezzi 07-02-2012 07:48 AM

Is there a wire that was left off thr battery?

zagu 07-02-2012 10:42 AM

I'm thinking fuse also...

now the next thing would be how do i get to the fuse box :( this is so hard... haha

as for wires on the battery i did not remove any other wire except the positive/negative to change the battery other than that did not do anything else.

zagu 07-04-2012 10:28 AM

okay just checked the fuse M10 (15amp) no problem whatsoever the contacts are still in place.

any other ideas?

bbtj 07-04-2012 04:27 PM

The only other thing I got is to check the wiring, make sure it is all connected properly.

bbtj 07-05-2012 10:41 AM

You might also want to check and make sure that there aren't any other fuses, such as an in-line fuse.

Dianeakamommy 09-29-2012 10:13 PM

What was the problem? I had mine jumped at my kids school and now nothing. Fuses where also fine.

zagu 10-26-2012 02:27 AM

anyone can help me on this. checked the fuse using a tester and its all good... as for the wiring how do i check if a wire got disconnected? i never touch any wires tho. Thanks

eboven 10-26-2012 02:49 PM

There are multiple fuses that will affect the power to the radio. Check each individual fuse in the Jeep just to be sure - one fusebox behind the glovebox, and one under the hood in front of the battery.

zagu 10-27-2012 04:01 AM

how do i open the fuse box behind the glove box? any idea? thanks been searching the net and cant find anything about it

Iceman 10-27-2012 07:41 AM

The fuse box behind the glove box is "open." Open the glove now and remove it (slide the retaining strap out and lift the GB out.) The fuse box is mounted to the firewall behind th glove box amid has no cover.

zagu 10-28-2012 12:07 AM

i opened my glove box and remove "it" check inside i dont see any fuse or anything. i took pictures i will post it also so you guys could see and help me.
i have a 2010 jeep wrangler JK (unlimited rubicon)

im really frustrated already :( having no sounds for the past 3-4 months is killing me :(

http://s10.postimage.org/5rs4xj6f9/photo_1.jpg

http://s10.postimage.org/cw9y6kdol/photo_2.jpg

http://s10.postimage.org/rtif7kqx1/photo_3.jpg

http://s10.postimage.org/hxhc7xl51/photo_4.jpg

http://s10.postimage.org/46cv5pw79/photo_5.jpg

zagu 10-28-2012 12:38 AM

im starting to think the head unit (radio) is the one that is busted but i want to make sure also... tho i dont know why it happened without the fuse being busted...

Iceman 10-28-2012 10:30 AM

My apologies there is a us box there In a tj, didn't realize you were working on a jk. If you have a test light or multimeter c yo contest for voltage at the radio wiring connector. With the jeep on you should have 2 pos 12 volt wires.


All times are GMT -5. The time now is 11:32 AM.