Jeep Wrangler Forum

Jeep Wrangler Forum (
-   TJ General Discussion Forum (
-   -   HELP!! 2.5l to 4.0l swap no gauges no spark no fuel (

1997TJv2.0 07-11-2012 03:53 PM

HELP!! 2.5l to 4.0l swap no gauges no spark no fuel
Ok so i just swapped out the 2.5l in my 1997 TJ for a 4.0l out of a 1998 TJ sahara, I swapped over the engine harness and ecm and my gauges didn't work and had no spark and no fuel cranks all day. I went back and got the gauge cluster from the guy i got the engine from and now its also says no bus. The install was plug and play or so i thought. Known differences are the ecm was out of an automatic, the plugs for the o2 sensors needed to be swapped out and the vehicle speed sensor plug needed to be switched for the 1997's I am about at my wit's end. I am a mechanic so i've covered the basics, fuses, grounds, etc. This really heas me stumped. Just for shits and giggles I replaced the crank sensor even though the one i had came from a running jeep. Anybody got any ideas? I'm open to all suggestions. All the diagnostic procedures point to a bad ecm but i have a hard time that the ecm could go bad from a car ride in a cardboard box from one place to another. Anyone in south jersey have a good ecm i could try? Can come get it. :banghead:

Yoshiltz 07-11-2012 05:59 PM

Check for ASD (auto shut down) system not functioning properly. I have had trouble with them in the past when doing swaps.

1997TJv2.0 07-11-2012 07:12 PM

Yeah the asd and fuel pump relays don't seem to be energizing... at the same time I'm having a hard time tracing wires because the service manual colors don't seem to match my wiring. PDC has power.

All times are GMT -5. The time now is 03:24 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.