Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   turn signal problem (http://www.wranglerforum.com/f218/turn-signal-problem-174755.html)

xnkuc10 07-18-2012 10:45 PM

turn signal problem
 
I have a 95 wrangler. Recently the turn signals have started to stop working but then will come on again. When not working it makes a squeaking sounds every time you hit the turn signal level and the inside indicator comes on for a split second then goes away. However, it is spuratic when they decide to work. I have checked the fuse it seems to be fine. Didnt know if anyone had any ideas before I go ripping the steering column off or something drastic.

Rednecksedan 07-19-2012 08:47 PM

Have h checked flasher box?

OverkillYJ 07-19-2012 09:12 PM

Sounds like a bad ground, not sure about the squeeky noise though.

Rednecksedan 07-20-2012 11:16 AM

I'd check to make sure it's not your flasher box just switch it with your hazard one if they work then you no u need it if they don't then go from there

cakes567 07-20-2012 11:42 AM

Also make sure your battery is.charged fully. My turn signals get really screwed up if the battery is low

0III0forlife 07-21-2012 12:34 PM

I would say its the flasher...look up under the drivers side of the dash.

the fuse box...it has to round aluminum flashers plugged into it....i believe the left one is for the signals, and the right one is for the hazard flashers. they are both the same and inter-changable to do the test that was stated above.

pull the signal flasher and repalce it with the hazard flasher to see if that cures the problem.


All times are GMT -5. The time now is 01:36 PM.