Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   loss of power at certain speeds (http://www.wranglerforum.com/f282/loss-of-power-at-certain-speeds-175989.html)

2002apexedition 07-24-2012 09:41 PM

loss of power at certain speeds
 
I have a 2002 jeep wrangler and all the power "seems" to be there from stop to go or low speeds but when i get to mid to higher speeds a lot of times it barely pics up speed or even looses some on bigger hills. not sure if its just a fuel filter problem or something more serious? It seemed to start doing this after i had my fuel tank lowered due to evaporative emissions system problems.

bvblzr 07-27-2012 04:04 AM

****Bump*****

My 97 4cyl Auto is doing the same... Taking off is great. Getting up to 50pmh seems like a choir and once I hit 60 as soon as I go up slight upgrade, back to 40-45.

1997 4cyl, Auto, 33" tires, 4" lift, stock 3:73 gears.

Gunner 07-27-2012 04:20 AM

Two different problems.
2002 yours started AFTER work on the tank. Thereby making the possibility of a kink or leak a possibility.
Bvblzr you don't state if this is new or not. If it is an on going problem your most likely suffering from 2.5itis. It is compounded by the addition of a power robbing automatic trans. My YJ has the same problem but it is a stick. The fix it to install a 5.3 LS motor and call your mechanic.
Seriously you have 3.73's and 33's with an auto. That is a tough combo for a 2.5 to push. Gears are gonna be your friend. Maybe 4.88's

Hoagie. 07-27-2012 05:39 AM

Ahaha 2.5itis is great. but yeah check your lines, trace your problem back and see if you have any leaks or kinks

2002apexedition 07-27-2012 11:33 AM

Thanks for the help

bvblzr 07-30-2012 03:30 PM

Thanks for the help as well. Regearing is for sure next!!

bvblzr 07-30-2012 03:32 PM

Quote:

Originally Posted by Gunner
Two different problems.
2002 yours started AFTER work on the tank. Thereby making the possibility of a kink or leak a possibility.
Bvblzr you don't state if this is new or not. If it is an on going problem your most likely suffering from 2.5itis. It is compounded by the addition of a power robbing automatic trans. My YJ has the same problem but it is a stick. The fix it to install a 5.3 LS motor and call your mechanic.
Seriously you have 3.73's and 33's with an auto. That is a tough combo for a 2.5 to push. Gears are gonna be your friend. Maybe 4.88's

Would 4.88's or 4.56's better?

rrich 07-30-2012 08:22 PM

Gears are always a good thing - but having the tank worked on did not make your gear ratio worse.

If it is a kink in the line - a fuel pressure test will show it. At the speeds it's starving the pressure will drop.

the 4.0 sounds like maybe a coil rail's going bad.

MVintherTJ 07-31-2012 01:06 AM

Quote:

Originally Posted by bvblzr (Post 2636774)
Would 4.88's or 4.56's better?

4.88s would be ideal for the 4cyl automatic with 33" tires.


All times are GMT -5. The time now is 07:05 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.