Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   Hard Start and Crank Position Sensor (http://www.wranglerforum.com/f19/hard-start-and-crank-position-sensor-176059.html)

TahoeTom 07-25-2012 10:54 AM

Hard Start and Crank Position Sensor
 
Hey Guys,

I tried doing a search for this but only found info on the 4.0.

My wife has a 97 TJ 2.5L and it's having some trouble starting in the morning. Nothing too insane, takes about 6-8 seconds of cranking before it catches. Then it will idle fine for about 30-45 seconds and then start an extremely rough idle. This goes away once you apply some throttle and then doesnt come back again unless the jeep has been sitting for a little while.

No check engine light but the OBD reader is signifying no detection of the crank position sensor- bottom line is.... Could this be causing this problem??

If so, where can I find the CPS on a 2.5L? I know it is supposed to be towards the top of the bell housing but I am not finding it. Can someone give me a bit more specific insight as to where it is on a 2.5L??

Thank you all, I look forward to becoming a part of this community!

boonie 07-25-2012 11:36 PM

Drivers side of bell housing towards the top. Has two bolts holding it in place (10 mm wrench size) and a wire connection up towards the manifold. Takes about 15 min to change about $75-100. Just did mine on same vehicle for the second time.

boonie 07-26-2012 07:38 PM

Sorry 11mm socket. Got it mixed up with something else.

tjrox 07-27-2012 01:42 PM

Check the o2 sensor, with engine c
old, if it shows ready it is bad.


All times are GMT -5. The time now is 05:24 PM.