Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   engine light on sometimes???? (http://www.wranglerforum.com/f210/engine-light-on-sometimes-17980.html)

ct-tj 04-24-2008 08:43 PM

engine light on sometimes????
 
Hey all, my 02 sport started this funny thing yesterday-- light popped on while driving down the highway. I pulled over and did the "push in the odo reset and turn key to run" thing. The system came back with no faults. Then the light goes off today and came back on while coming home tonight. Any help would be awesome. Thanks.

richp 04-24-2008 08:47 PM

Remove and retighten your gas cap for a start, stop at Advanced Auto and go buy a $80 OBDII scanner that will do resets or just have them read it to see what the code is. Having the scanner is handy, they also have a small one that you can install in the dash and monitor as you drive.
http://www.thinkgeek.com/gadgets/electronic/8426/

ct-tj 04-24-2008 08:50 PM

rich, that scan module is the coolest thing ive seen in long time. Thanks for the heads up. wont the cap being loose throw an evap code though?

4.0l sahara 04-24-2008 08:53 PM

yes evap leak code.

richp 04-24-2008 08:54 PM

Quote:

Originally Posted by ct-tj (Post 222294)
rich, that scan module is the coolest thing ive seen in long time. Thanks for the heads up. wont the cap being loose throw an evap code though?

Should but it can also be a cap going bad, thats why the scanner is handy to have all the time, then the error shows up right away as you are driving. For odd problems I grab my customers/friends Snap-on modis box and go for a drive, then look at the entire history of everything from injector pulses, O2 sensor response times, etc. But thats a $5K tool and waaaaaaaaaaay outta my price range...

ct-tj 04-24-2008 09:15 PM

I would love to have my own snap-on reader. Tomorrow Im headed to the shop I used to twist wrenches at and try to borrow their scanner for a few. Ill let you guys know what I find. Thanks for the help.

MNPHINZ 04-24-2008 10:33 PM

The only light that is starting to annoy me is that little shift arrow:banghead:

ct-tj 04-25-2008 12:04 AM

I just took the dash apart and painted that damn arrow black. I even forgot it was there till you reminded me. I really hated that thing!

MNPHINZ 04-25-2008 07:29 PM

Quote:

Originally Posted by ct-tj (Post 222364)
I just took the dash apart and painted that damn arrow black. I even forgot it was there till you reminded me. I really hated that thing!

Not a bad idea! It's nuts, as soon as you step on the gas, even under 5mph it wants you to shift! Sorry to bring up the PTSD of the light!

ct-tj 04-25-2008 08:03 PM

Back to the original issue.... sort of. I was at a friends house and noticed a ton of fluid on the ground... thought the tranny had a hole in it or something. Sooo.... I took it to the shop, no fluid in the tranny and a blown shifter seal. Good news, a little RTV and two quarts of fluid later, all better. And the light which I completely forgot about is off..... mabye it had to do with the low fluid???? Ill never know. Just my luck, itll turn on tomorrow anyway.

Triple88a 04-25-2008 08:05 PM

haha "7 mpg", is the mpg on it by any chance accurate? lol.
http://www.thinkgeek.com/images/prod...an_guage_2.jpg

ct-tj 04-25-2008 08:10 PM

at 129mph I would have to say....... maybe????

ct-tj 04-25-2008 08:10 PM

Hey trip, you stole my bumper....

Triple88a 04-25-2008 08:14 PM

i bought it first :) hehe


All times are GMT -5. The time now is 10:59 AM.