Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   WF New Member Check In (http://www.wranglerforum.com/f12/)
-   -   Huge Problem (http://www.wranglerforum.com/f12/huge-problem-180517.html)

cjgagnon 08-14-2012 10:12 PM

Huge Problem
 
I left my top off my 09 Jeep Wrangler and went to work. I left the top off because it was supposed to be a slight chance of rain in the evening so I was going to put it on when I got home. Unfortunately it rained while I was gone and apparently rained pretty good. I wasn't really concerned with it until I got in it later that evening. I turned the key and no power to anything. No lights, no radio, no dash lights, nothing. I checked the battery and it is showing a good charge. I checked all the connections and everything is tight. I checked all the fuses including the main and they are all good. I've let it dry for a couple of days now and still nothing. Has anyone had an experience like this or have any suggestions? I'm trying to keep from having to get it towed to the shop, expecially if it is something simple that I am overlooking.

SilverSport 08-14-2012 11:19 PM

Welcome Aboard! :wavey: This section is where we welcome new members so you may not get many answers. Post your question in the JK forum.

MrSig 08-15-2012 04:00 AM

http://r23.imgfast.net/users/2314/13...3032514546.gif and enjoy the forum!

blkrubi88 08-15-2012 04:27 AM

Welcome!

Beastmaster 08-15-2012 06:15 PM

Welcome to the forum! :wavey:

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)


All times are GMT -5. The time now is 11:17 PM.