Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   1997 Wrangler sport - no fuel at injection rail, replaced fuel pump, still no fuel. (http://www.wranglerforum.com/f218/1997-wrangler-sport-no-fuel-at-injection-rail-replaced-fuel-pump-still-no-fuel-180540.html)

richardjefferson 08-15-2012 01:34 AM

1997 Wrangler sport - no fuel at injection rail, replaced fuel pump, still no fuel.
 
Good Evening All. Im a newbee to this forum looking for technical help. heres the scoop. My baby (1997 Jeep Wrangler Sport) decided to stop running on me.
The symptoms started a couple weeks ago. Jeep would not start up after sitting for about 10 min. Finally started up (dont know why). Then same thing happend about 5 starts later. just turned over but wouldnt fire. I suspected it could be a fuel pump so i rapped on the gas tank a few times and it fired up.
well it started up on for the next 15 to 20 starts. Cool i figured i must be out of the woods and mabey it was water in the gas.. just then... it died but this time while i was driving it. just acted like it ran out of gas. Well i towed my baby home and prepared for one of the repair jobs i just love..dropping the tank and replacing the fuel pump. Fast forward to tonight. I got a new fuel pump from NAPA, installed it. The only glitch i ran into was that the electric connector on the new unit did not fit. I had to drop the tank again and splice the connector from the old pump onto the new pump. Got everything back in place. Added 5 gallons of fresh gas and tried to start her up ... Nothing.. Turns over like a champ but wont fire. The sending guage shows gas in the tank but there does not seem to be more then a dripple of gas from the pressure release valve on the fuel injection rail. That puppy should be shooting out. soooo im not getting fuel to the rail.

Any ideas from this forum would be appreciated. im stumped. My next step is to check the voltage to the pump. im assuming it should be a straight 12 V when the ignition is turned on.

Thanks!
Rick

dnr421 08-15-2012 09:16 AM

Have you changed the fuel filter? Also when your checking voltage to the pump remember it only gets power when you initially turn the key on, and when you spin the motor over. So you might need assistance when checking for power to the pump

richardjefferson 08-15-2012 10:00 AM

Good Mornng dnr421. Thanks for your thoughts. The fuel filter on this model is a part of the fuel pump assembly and is inside the tank. There is no fuel filter external to the tank. But.. by replacing the entire pump assembly, i have replaced the fuel filter.

Thanks for the tip about checking the voltage. I thought it got power so long as the ignition was in the on position. I did not know the engine had to be cranking. Ill get some help to check this out. I wont be able to get back on it until tonight so i appreciate the tips and suggestions that i can try out tonight.

richardjefferson 08-15-2012 11:56 PM

Update - its not the fuel pump. Iim not getting power at the connector when i turn on the ignition. i switched relays and that is not the problem. i had a blown fuse for the fuel pump. Changed that and still no change. im not good at tracing wires back and not very good at reading schematics. I dont know if the power and ground run thru the computer or go direct to the power distribution box where the relay is. maybe its time to tow it to the garage and take my lumps.

Deadenduser 08-16-2012 12:09 AM

I had similar problems with my yj but since you have a tj I'm afraid to recommend anything because yours has a more intricate computer and the wiring will probably be different. You should try posting this in the TJ forum.

richardjefferson 08-16-2012 12:29 AM

Hi Deadenduser, it is a YJ. im thinking the next step is to replace the computer.

Deadenduser 08-16-2012 12:43 AM

I never heard of a YJ from 97 because that is the first year of the TJ but if you sure who am I too argue.
Also If it is a YJ you most certainly have an external fuel filter (unless someone replaced your fuel system with something completely after market.) it will be right above the front of your rear passenger tire on the frame. it will look like http://www.quadratec.com/Assets/Imag...1/33751-lg.jpg Just follow your fuel lines and there it will be.

Anyway if that still fails (like mine did) It may be a break in your wiring. My jeep had a fault leading up to my fuel pump relay as well as one in the actual line leading to the pump.

I did a bit of hack job to fix the problem and ran a new ground and power line to my pump
As seen here: http://img42.imageshack.us/img42/5360/p08101207322.jpg

richardjefferson 08-16-2012 10:24 AM

Deadenduser - your right. its a TJ. i had a brain fart. just got a 94 wrangler for my step daughter about 4 weeks ago and thats a YJ. Im going to repost to the TJ forum

the '97 does not have the fuel filter, but i have an electrical problem. I think your dead on with my problem and im going to have to do the same thing.

Your pic is great! Im not at the garage to double check but im pretty certain my realy had 5 leads also but they are in a different pattern.

to confirm, it looks like you ran three leads from the relay to the socket in the power control module and one directly to the pump and one (the middle) nothing. on your YJ, you have wires from the fuel pump motor. I assume one is the lead from the realy in your pic. does that run direct to the pump or through the computer? Is this the hot lead? If this is the hot lead, where does the other lead (the ground) go?
Thanks For your reply. much appreciated.
Rick.


All times are GMT -5. The time now is 09:46 PM.