Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Idle issue at stop. (http://www.wranglerforum.com/f210/idle-issue-at-stop-180588.html)

Dory 08-15-2012 10:10 AM

Idle issue at stop.
 
This is my first post and any help would be greatly appreciated. I have a 2004 Wrangler that has just started giving me issues. At stops it will idle between 800 rpms, make a slight clicking noise from the engine, and switch to around 1500 rpms and then lower back down to 800. Also, periodically when I attempt to climb a hill on the freeway, the rpms will jump from 2000 to 45000 going 60-65mph. After a couple attempts of letting off the gas, it will stabilize back to normal. I don't know if this has anything to do with it, but I just had the oil changed and valve cover gasket replaced due to a leak. Again, any help is greatly appreciated.

scott howard 08-15-2012 04:53 PM

I would replace the tps

Jerry Bransford 08-15-2012 05:00 PM

Yep that sounds like a defective throttle position sensor (TPS) which can be replaced with a simple torx-head screwdriver in maybe five minutes.

soxfan69 08-15-2012 05:08 PM

Jerry, will a tps show a #1 cylinder miss fire?

Jerry Bransford 08-15-2012 05:11 PM

Not that I've ever seen or heard of.

HarryJeepGuy 08-15-2012 06:47 PM

Quote:

Originally Posted by soxfan69
Jerry, will a tps show a #1 cylinder miss fire?

Quote:

Originally Posted by Jerry Bransford
Not that I've ever seen or heard of.

When my TPS went bad and my engine bucked hard enough, I did get misfire codes. It was revving in first gear, going uphill out of my driveway. It would lunge and buck like crazy. It felt like the engine turned off for a second or two, then was floored. What can you do? Change the TPS, disconnect the battery overnight, and see what you have.

soxfan69 08-15-2012 08:38 PM

I've got an exhaust leak either on the manifold or on a header tube..haven't gotten too deep into that yet. But I've replaced the cat,exhaust,o2 sensors and done a hard reset on the ecm and the clock spring. Just goin down the list till I run out of ideas or patience. Whatever comes first. Any other suggestions?

mickeygriffin 08-16-2012 05:36 PM

burning gas like crazy?

soxfan69 08-16-2012 07:21 PM

not more than usual, about 12-14 mpg... i can smell the cat when running around 75. check engine light goes on and off intermittently. I ordered a new exhaust manifold today. i'm guessing the leak i have is throwing the ecm off.


All times are GMT -5. The time now is 09:28 AM.