Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   WF New Member Check In (http://www.wranglerforum.com/f12/)
-   -   new to forum need jeep expert help!! (http://www.wranglerforum.com/f12/new-to-forum-need-jeep-expert-help-181532.html)

90wrangler123 08-19-2012 05:46 PM

new to forum need jeep expert help!!
 
hey i just got my membership here after always going here anyway to lean more about my jeep. but no threads were able to help me with my very very odd problems. i have a 1990 jeep wrangler with the 2.5l tbi engine and 5 speed trans, it has 85k. it has a brand new radiator, water pump, and thermastat, also i have the heater core looped off as it was also bad. it runs between 210 and 230 degrees and i can not get it to run at the 190 it should be at. i have never heard of anyone with this problem so if anyone could help me that would be great.

kbwwolf 08-19-2012 06:01 PM

Post here: YJ Jeep Wrangler Forum

This is just where we greet peeps. Welcome to WF! :thumb:

hbgirl 08-19-2012 06:58 PM

:wavey: welcome 90wrangler123!

Beastmaster 08-19-2012 10:43 PM

Welcome to the forum! :wavey:

_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

MrSig 08-20-2012 03:14 AM

http://r23.imgfast.net/users/2314/13...3032514546.gif and enjoy the forum!

blkrubi88 08-20-2012 04:30 AM

Welcome!

dabolt55 08-20-2012 06:50 AM

Welcome and good luck with your issue..:thumb:

JDsDream 08-20-2012 07:51 AM

Welcome to the Forum

I'm not sure about the proper running temp for the 90 model, but 210 is normal for my TJ.

SilverSport 08-20-2012 08:47 AM

Welcome Aboard! :wavey:

90wrangler123 08-20-2012 10:12 AM

i moved my post to the proper place now. thanks for welcoming me in!


All times are GMT -5. The time now is 05:31 PM.