Jeep Wrangler Forum

Jeep Wrangler Forum (
-   Massachusetts Jeep Forum (
-   -   Problems with 4WD (

scrap93 08-20-2012 06:12 AM

Problems with 4WD
The other day I was pulling a jetski/ trailer out of the water on a ramp (not very steep at all). I went to engage the 4WD and the lever just clicked/ popped. It did not engage. Now the lever just moves freely and does absolutely nothing. Can not engage 4WD. I know you're not suppose to force it into 4WD and don't feel that I did. The engagement of 4WD has always been awkward at best. Any thoughts on this? Thanks.

skendall 08-20-2012 07:12 AM

I would hope the extent of your damage is as simple as a broken piece of linkage or shifter bracket. That would be much cheaper than my second guess-(gearbox).

robskully 08-20-2012 09:11 AM

If you live close to Nashua then you should try these guys.
From what I have heard they are really good.
I have no affliliation with them but heard very good reports
about them and my buddy has used them.
Elias 4 Wheel Drive Center

Rob ....

chidychi 08-20-2012 09:27 AM

If you are driving a JK than search the forums.
There are multiple threads regarding this problem.
Something about a small $0.50 plastic clip that breaks and needs replacing.

scrap93 08-20-2012 11:07 AM

Thanks. I'm hoping it's just a quick fix and a small piece of hardware that needs to be replaced. Thanks for info. I'm going to look into Elias.

chidychi 08-21-2012 07:31 AM

This might help you out:
There is a part number in the second post.
It sounds like the problem that you have.

N3M0 08-21-2012 11:17 AM
check that thread, most likely its the .05$ plastic piece mentioned

All times are GMT -5. The time now is 04:00 PM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.