Jeep Wrangler Forum

Jeep Wrangler Forum (
-   TJ General Discussion Forum (
-   -   Slight vibration after front pinion seal replacement? (

ryanhewitt 08-22-2012 08:39 PM

Slight vibration after front pinion seal replacement?
This past weekend I replaced the leaking front pinion seal on my low pinion dana 30 (01 TJ). I chose the "put everything back exact" method. I marked the front drive shaft, pinion yoke, u-joint, pinion nut, and pinion threads.

When I drive the jeep at 65-70 mph I think that I'm feeling a very slight vibration in my hand through the steering wheel. There is no excessive noise, or heat. There is no play in the pinion yoke.

Am I just hypersensitive after this seal replacement? How long would it take before I would know that I definately didn't put something back to it's original location? And finally, what should I expect if something isn't correct (a bunch of noise, grinding, howling, etc.)?

Thank you in advance.

Jerry Bransford 08-22-2012 08:43 PM

Sounds to me like you got the pinion nut back to where it should have been, I'd look for a different cause of the added slight vibration if it's not just from an overactive imagination. :)

ryanhewitt 08-23-2012 08:49 PM

Thank you

Thank you for the reply. Nothing else was changed so it must be in my head. I'll keep you posted if I notice anything different.

All times are GMT -5. The time now is 03:31 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.