Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Zone 4.25 combo lift question (http://www.wranglerforum.com/f282/zone-4-25-combo-lift-question-188010.html)

niisan9178 09-19-2012 01:04 PM

Zone 4.25 combo lift question
 
So I finally decided on the zone combo lift. Over the weekend I installed the suspension (3 inch), but ran out of time for the body lift and motor mount. So I drove it home and think that those 3 inches look great right now, there is no need to put the rest of the kit on at this point. I was happy with this thought process until a friend of mine informed me that the increased angle of the ds needs to be rectified. So I asked around and have gotten conflicting reports on what I should do. Some people say 3 in is fine, others say put the motor mount and body lift on.

(sorry for the wall of text)

txstj 09-19-2012 04:46 PM

More often than not TJ's need a t-case drop at 3" if a SYE is not being used, but sometimes you can get away without. Notice any vibrations under accel, decel, or at all? If you're getting driveshaft vibs, adding a t-case drop should be the fix, but if not you should be fine running without.

O - we need pictures, or the lift install never happened! :D

niisan9178 09-19-2012 04:52 PM

Right now I have no vibrations except when I am decelerating and I go from 10 mph to 5 mph relatively quickly. But that might be the super swamper boggers that I have on there ;)

And I had before pics on my phone but it decided to die some time during the lift installation. I do have after pics, will try and post them later tonight.

Verdl 09-20-2012 11:25 AM

I have this combo and can't wait to get it installed. Every time I think I'll get a break for work I'll have taskings come donw. Maybe next week...
Looking forward to pics and hearing more about how it all works out for you.

niisan9178 09-20-2012 05:30 PM

2 Attachment(s)
OK here are the pictures, with just the 3in suspension. No body lift or motor mount.

Any other thoughts on the potential driveshaft angle?

DarthLEGO 09-20-2012 05:34 PM

Looks good... and post more feedback after a few days if you can. I am seriously considering that exact mod.

(Love the quote!)

stircrazy13 09-20-2012 05:39 PM

x'2 looks great..

niisan9178 09-21-2012 01:26 PM

Update:
Got the tires balanced and that reduced the frequency of the death wobble. I still get it maybe 5% of the time? Ugh

Still no vibrations other than what I assume is the tires that I mentioned in a previous post..

Check engine light popped on. The code is 1494. So off i go to research this new development..

niisan9178 09-28-2012 07:03 PM

Alright so an update:

Disclaimer: I am not an automotive terminology expert, so please forgive the vague-ness

I looked under the hood and noticed a hose had popped off from the engine (area). So off I went to the parts store and picked up some clamps that require pliers to pinch. Reattached the hose, and the check engine light went off today!

So now I am back to my original dilemma,
Do I need to install the body lift and motor mount or am I ok with just the 3" suspension?

Verdl 11-23-2012 02:29 AM

Any updates or changes? Time is still an issue with me and I'm thinking about breaking this up and installing just the suspension today. Anyone else know if that will cause issues?

ob269 11-23-2012 05:16 AM

Quote:

Originally Posted by Verdl
Any updates or changes? Time is still an issue with me and I'm thinking about breaking this up and installing just the suspension today. Anyone else know if that will cause issues?

From what I've seen, there shouldn't be any issues other then maybe needing some washers for a tcase drop..

Verdl 11-24-2012 03:06 PM

So I spent way too much time on the front end springs/shocks today and have the back end to finish up tomorroe. Any help for getting the 4 bolts off the rear shocks? They're tucked away at bad angles in tight spots. I keep hearing the back end goes easier. I'm hoping so...any help now is appreciated.

GoldenSahara00 11-24-2012 03:12 PM

At least install the mml. You will be sure your driveline angle is fine, and it won't give you anymore lift. I would add the BL however. It looks better.

Verdl 11-24-2012 03:31 PM

That's the plan for after the back is done-i don't mind waiting on the BL. Do you have anything for the rear shocks? Can I break them off Luke I did with the front?

BLK00TJ 11-24-2012 03:43 PM

I had vibes even with the MML and 3" suspension lift. I had to drop my T-case with 3 washers on each bolt adding up to about a 3/8" drop. Barely noticable but it ticks me off. I should have the cash to do it right by spring along with a tummy tuck and other junk.

GoldenSahara00 11-24-2012 03:44 PM

an impact really helps with the shocks.

Coasttrash 11-24-2012 09:04 PM

I dont remember mine being all that hard to do. I just used hand tools to do it.

JDeBlois 11-25-2012 12:05 AM

Yeah man, just hand tools were good on mine. I used air though, because it was available. Haha the only bad part was getting the rear shocks in the mount

Coasttrash 11-25-2012 01:51 AM

yeah putting the rear shocks back on was interesting to say the least also the rear trac bar bracket was entertaining. If my compressor was working I would have used the impact ha.

Verdl 11-25-2012 02:16 AM

So not much if a break on installing the back end? I was really hoping on a smoother day!

Noish 11-25-2012 03:49 AM

The back on mine was smooth. I just went slow because of the fear of breaking a bolt. I did the whole 4.25" and have slight vibes between 30-34mph. Probably will add washers to the tc and see if that helps though it isn't bad as it is.

Verdl 11-25-2012 11:52 AM

I got close to finishing today-shocks and springs are mounted, all that's left is connecting my sway bar links and the rear track bar. I didn't have help today and snapped a hose on the driver side just behind the track bar relocation bracket I mounted to the axle. Anybody know how bad that might be. I was chased out of the garage before I could finish up. New winter hours have them close 2 hours early.

patspoth20 04-25-2013 11:53 AM

Quote:

Originally Posted by Noish (Post 3030251)
The back on mine was smooth. I just went slow because of the fear of breaking a bolt. I did the whole 4.25" and have slight vibes between 30-34mph. Probably will add washers to the tc and see if that helps though it isn't bad as it is.

I'm having the same problem 30-40mph. Did the washers fix the vibrations?

Noish 05-14-2013 06:49 PM

Honestly for how slight the vibes are it just wasn't worth it to me to get out in the cold for 5 minutes. Ill probably do it when I get back to the Jeep in around a week. I'm expecting it to help since a lot of people just do that with a lift and we have the motor mount lift on top. Wont hurt at least


All times are GMT -5. The time now is 10:31 AM.