Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Canada Jeep Forum (http://www.wranglerforum.com/f119/)
-   -   Any jeeps in canada ticking? (http://www.wranglerforum.com/f119/any-jeeps-in-canada-ticking-188258.html)

Johnny Vintage 09-20-2012 02:12 PM

Any jeeps in canada ticking?
 
I've been an avid reader on the Jeep Wrangler USA site and man, they sure sound like they are having a real bad problem with the heads on the new engines. Seems like every day about 3 or 4 more more people say they are getting there heads replace at anywhere between 1000 and 10,000 miles.:eek:

I emailed my Jeep dealer service department. They are a very large dealership and told me they have sold tons of Wranglers and have not had one problem with the heads.

Any of you fellow Canadians had this ticking and head problem?

Below is the e-mail response from the Service Manager:

My apologies for taking so long to get back to you but I have been away.

Congratulations on the purchase of your new Jeep, Iím sure you will enjoy it!!

I have checked TSBís on your vehicle and there is currently nothing there regarding cylinder heads causing bad ticking and then a light coming on. Although Iím sure some customers may have experienced this problem and had it repaired, it is far from a common problem. We are a fairly large dealership and have not performed even one such repair. Should you develop such or problem, or any problem for that matter, please feel to contact us to schedule an appointment. In addition to this, we offer a free road test service on Monday through Friday between 7:30am and 3:00pm. Should there be anything you are unsure of, or a noise you are concerned about or would just like clarification of how to use some of the options on your vehicle, please feel free to drop by.

As a further note, every single time we write a work order on your vehicle, we automatically check it for recalls. This is something the computer does for us without prompting. Should there be any outstanding recalls we are notified immediately. Recalls are very specific to the VIN of your vehicle and can apply to only some vehicles. ie, your friend may have ďthe sameĒ vehicle and end up with a recall that does not apply to your vehicle.

I hope this puts your mind at ease.

Regards,


Scott Polegato
Service Manager
Coquitlam Chrysler
604-469-5640

Mulmur 09-20-2012 07:00 PM

I am awaiting delivery (order mid-august) of a 2013 Sahara from Blue Mountain Chrysler in Collingwood, Ontario and asked the service manager the same question and he said he had not had any issues with heads/ticking.. They also sell a lot of jeeps.
My guess is that although there are hundreds, or perhaps over a thousand jeeps with this problem, it is still a small sample compared to the number sold over the last few years so I assume the chances are slim ??
I'm hoping that the 2013 engines are beyond this issue.. but who knows.

JKPaul 10-04-2012 08:57 AM

my 2010 JK had what I thought was a bit of a tick until I switched over to synthetic oil, sound was gone after. I don't own it but another family member does, it has 12000km on it, still on synthetic oil and still sounds OK, no tic. My 2012 with the new Penstar sounds fine so far

Peter T 10-14-2012 12:29 PM

Just turned over 8000km everything is still fine. Well except for the random wipers coming on and I can't turn off :whistling:

mackdj1 10-16-2012 06:55 AM

Just hitting 5000Kms. Nothing yet. Mine was born in May 2012 so it's in the right build time for the tick to occur.

JKPaul 10-17-2012 10:28 AM

I read and understood that any builds done in 2012 were ok, that it was the builds done in 2011 that had the problem? Am I mis-informed?

Johnny Vintage 10-17-2012 11:09 AM

Go on the American Jeep Wrangler Forum. There's about 75 pages of people with the tick. All years with the new motor including the 2013's.

So far I'm good but I've only got about 2,500 k on it. Sounds like it comes on around 5,000 to 10,000.

Not good!!!

mackdj1 10-17-2012 01:29 PM

Quote:

Originally Posted by Peter T (Post 2888669)
Just turned over 8000km everything is still fine. Well except for the random wipers coming on and I can't turn off :whistling:

I've heard of this problem in a couple of threads. Has the dealer fixed it yet?

Dick Blonov 10-17-2012 04:28 PM

Quote:

Originally Posted by JKPaul (Post 2898708)
I read and understood that any builds done in 2012 were ok, that it was the builds done in 2011 that had the problem? Am I mis-informed?

My 2012 was built in 2011. 21,000KM. No ticking :)

Luck (or lack thereof) of the draw.


DB

sanchese 10-20-2012 05:52 PM

my jeep rubicon was built june 2012. it has 7500km with no tick and no problems so far. I love my jeep! It is so fun to drive!

Holly84 12-31-2012 12:12 AM

I have a 2012 and I have the ticking and trust me its annoying... Had it to 2 dealerships and neither one can figure it out... Good luck

JKPaul 01-01-2013 08:45 AM

OK, just approaching 6000km on my 2012, running synthetic, it sounds great, so far. Only noise I had was a vibration in the rear, it was the heat shield over the muffler, grabbed one corner, applied a little pressure, all OK at this time.


All times are GMT -5. The time now is 07:03 AM.