Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Jeep wont start, cranks, rolls over fine, replaced fuel pump...nothing. (http://www.wranglerforum.com/f210/jeep-wont-start-cranks-rolls-over-fine-replaced-fuel-pump-nothing-189533.html)

1999JeepWrangler 09-26-2012 06:39 PM

Jeep wont start, cranks, rolls over fine, replaced fuel pump...nothing.
 
Replaced fuel pump three times, checked fire getting back to fuel pump, checked the fuel pump pressure, it's fine; replaced spark plugs, replaced pick up coils, added a starter sensor. Nothing will work, it sounds nice cranking, put gas in corroborator, cranked right up but somehow after three fuel pumps it wont catch a fire. Saw something else about someone who jumped his fuel pump relay and hooked straight on the battery? Wondering if someone else has heard/done this. Never heard of it but he seemed to have the same problem as me. Also have been reading about something called the ECU or the ADS Not sure where it's located, but thought that might be a problem? Could someone else help out with this? It's been sitting a while in the driveway, at first it started but now, nothing. Could I run a direct wire to the fuel pump hookup? Kind of new to this...any help would be greatly appreciated.

4wheelin 09-26-2012 07:35 PM

Quote:

Originally Posted by 1999JeepWrangler
Replaced fuel pump three times, checked fire getting back to fuel pump, checked the fuel pump pressure, it's fine; replaced spark plugs, replaced pick up coils, added a starter sensor. Nothing will work, it sounds nice cranking, put gas in corroborator, cranked right up but somehow after three fuel pumps it wont catch a fire. Saw something else about someone who jumped his fuel pump relay and hooked straight on the battery? Wondering if someone else has heard/done this. Never heard of it but he seemed to have the same problem as me. Also have been reading about something called the ECU or the ADS Not sure where it's located, but thought that might be a problem? Could someone else help out with this? It's been sitting a while in the driveway, at first it started but now, nothing. Could I run a direct wire to the fuel pump hookup? Kind of new to this...any help would be greatly appreciated.

You didn't say where you checked fuel pressure. Fuel filter?
Crank position sensor?

tangofox007 09-26-2012 07:41 PM

Quote:

Originally Posted by 1999JeepWrangler (Post 2832993)
...checked the fuel pump pressure, it's fine...

What more do you expect from the fuel pump?

sargeparrish 09-26-2012 08:25 PM

Quote:

Originally Posted by tangofox007

What more do you expect from the fuel pump?

i would definetly check the ckp crank position sensor. if its out it aint gonna run. mine did the same thing. there like 50 bucks at auto zone. but i would go with oem from the dealer. i had to go thru 2 of them before i got a good one.

yjreyn 12-31-2012 06:13 PM

Bypassing ECU
 
Yes you can bypass the ECU, I have done this to my YJ. First, make sure the ecu is the culprit, check the voltage going to the injector when you try to start it and see if its getting 12V, if its not, then hook up a button to the positive wire going to the injector to a positive wire under your dash, I punched mine straight into the fuse box. When you go to start it push the button, this will shock the injector and cause the magnet inside to lift up delivering fuel to the carb. Good luck! ... Also, as a side note, I was getting tired of doing this and decided to replace my ECU and now that I have, my Jeep wont start at all... Not getting spark from the coil, I'm still in the process of diagnosing and that's how I stumbled upon your thread.


All times are GMT -5. The time now is 11:10 AM.