Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Hardtop wiring kit not working (http://www.wranglerforum.com/f282/hardtop-wiring-kit-not-working-190649.html)

Felber 10-01-2012 11:18 PM

Hardtop wiring kit not working
 
Today I hooked up my hardtop wiring kit on my 99 tj. I double checked to make sure everything was hooked up correctly according to the instructions. When i finished i tried the switches for the rear defrost and wiper and nothing happened. I checked the voltage at the 100 way connector and had nothing on the pins that i was required to use to hook it up. The fuses and relay had power. Where do i go from here?

RUBI 4 MY MRS 10-02-2012 01:37 AM

It sounds like your problem is at step #32. Did you find the red 10 pin connector at the BOTTOM of the 100 way connector group? The br/pk (cav #4) & the bk/wt (cav#1) are the main power supply for the wipers & defrost. They need to match up with the same color wires on the other side of that connector & either should have had those positions empty or the complete half of that connector missing & you would use the one supplied in the kit. If so make sure you got the wires all the way into the connector & locked into place. The other 2 in positions 2 & 3 are for the switch illumination when your lights are on. You can check that as well.

Felber 10-02-2012 10:00 AM

Yes I hooked that up properly and double checked to make sure the wires are in all the way. Cavity 1 and 4 have no power going to them for some reason.

RUBI 4 MY MRS 10-02-2012 12:44 PM

OK, starting with the bk/wt wire in the #1 cavity. Make sure the fuse you put in slot #15 is good then with the key on see if the relay you installed in step 22 clicks when you turn the defroster switch on. Also see if the #30 terminal in the relay socket has power (from fuse #15). When the relay closes it should power the 87 terminal from the 30. The 87 is the bk/wt wire in cav #1.

For the br/pk wire in cav #4, it should get power with the key on from fuse #6 in the block behind the glove box, check that fuse.



You can see the wiring diagrams in the FSM.

See online read only FSMs here:
Jeep Knowledge Base
You may have to go to the bottom of the page & pick Jeep Resources & online manuals if it directs you to home page rather than the knowledge base.

Felber 10-05-2012 07:41 PM

Thank you! I used the wire diagrams and figured out the the connector in the jeep was upside down compared to the instructions. I just plugged the connector in upside down and it all worked! Thanks Again!


All times are GMT -5. The time now is 03:41 PM.