Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Oregon Jeep Forum (http://www.wranglerforum.com/f62/)
-   -   has anyone in the NW had the dreaded tick yet? (http://www.wranglerforum.com/f62/has-anyone-in-the-nw-had-the-dreaded-tick-yet-190985.html)

Randy-S 10-02-2012 08:21 PM

has anyone in the NW had the dreaded tick yet?
 
I am sure we all seen the threads with the new JK's and the dreaded tick/head replacement. I was just curious if anyone here locally had to deal with it yet, and if they did how did the dealer treat them?

I have a 2012 with 5K on it and the only problem I have is prying the keys out of my wife’s hand :rolleyes:



http://img.photobucket.com/albums/v349/ranran/jeep.jpg

scoobyjeep 10-02-2012 10:29 PM

Quote:

Originally Posted by Randy-S (Post 2854665)
I am sure we all seen the threads with the new JK's and the dreaded tick/head replacement. I was just curious if anyone here locally had to deal with it yet, and if they did how did the dealer treat them?

I have a 2012 with 5K on it and the only problem I have is prying the keys out of my wife’s hand :rolleyes:



http://img.photobucket.com/albums/v349/ranran/jeep.jpg

i don't know if this appys to jeeps or not but the 3.6L in the grand caravans and town and country's have a TSB about a cylinder 3 misfire requireing head replacemnt

Randy-S 10-03-2012 10:42 AM

You would think it was more widespread then just the wranglers
I was interested in seeing how are local dealers were dealing with it.

scoobyjeep 10-03-2012 10:48 AM

Quote:

Originally Posted by Randy-S (Post 2856828)
You would think it was more widespread then just the wranglers
I was interested in seeing how are local dealers were dealing with it.

if its under warranty they have to fix the problem, i haven't dealt with any of the dealers. but jeep in Beaverton does decent work from what i have heard

Randy-S 10-03-2012 11:22 AM

I have not had to deal with any of the local dealers I purchased my jeep in Seattle
I live closest to dick Hannah but I can't say I am a fan of them

rvkillian 10-03-2012 02:23 PM

I bought my 2012 in May. 6400 miles with no tick yet.

scottmphoto 10-04-2012 02:21 PM

2012 Rubi here, 3k miles. Nothing yet.

Randy-S 10-09-2012 10:05 AM

Nice to hear the only problem I have with my jeep is trying to decide what front bumper I want to install

JKNW 10-10-2012 09:33 PM

2012 JK 4K no tick. Build date 2\12 I bought my from NW jeep in Beaverton. Very happy with the folks I dealt with when my gas tank cracked

Randy-S 10-12-2012 05:53 PM

So they treated well that's good to know my jeep new also and I can take it to any dealership I want if I do have a service issues

Blastek 10-20-2012 11:51 PM

i had my head replaced just over a month ago. runs great now. i got some really bad service in hillsboro, so i took it to T&C in wilsonville and they did a great job with the head.

edit, yes, i used the words bad, service, great, job, and head in the same sentence.

Randy-S 10-22-2012 10:14 AM

Quote:

Originally Posted by Blastek
i had my head replaced just over a month ago. runs great now. i got some really bad service in hillsboro, so i took it to T&C in wilsonville and they did a great job with the head.

edit, yes, i used the words bad, service, great, job, and head in the same sentence.

Can you give some more feedback about your experience? Age and miles on your jeep
How many trips to the dealer did it take.
How long did the repair take did they provide a loaner?

Blastek 10-22-2012 04:30 PM

Quote:

Originally Posted by Randy-S (Post 2913825)
Can you give some more feedback about your experience? Age and miles on your jeep
How many trips to the dealer did it take.
How long did the repair take did they provide a loaner?

my tick started at about 1k miles. late april build. I had it in at hillsboro and they said it was normal. brought it in at about 2k miles and this time they were willing to pull the valve cover and check. but, after they screwed up my oil change twice, I thought it best not to let them handle anything major, including pulling a valve cover.

wilsonville was much different. i had about 8k miles on it at this point, but still no CEL. I dropped it off at 8am, got a call at noon from enterprise asking me when i wanted to pick up my loaner (durango) before i even got in touch with the dealer.

they pulled the valve cover and had found found loose lifters. I had the jeep back 3 days later (due to waiting for parts and i also had the emergency brake replaced). I think the actual head repair took 1 day or less. so for T&C in wilsonville, it was 1 trip to drop it off, 1 to pick it up.

lovecomplex 10-22-2012 11:59 PM

edit: lol, oops, wrong thread :facepalm:

Randy-S 10-23-2012 11:12 AM

Quote:

Originally Posted by Blastek

my tick started at about 1k miles. late april build. I had it in at hillsboro and they said it was normal. brought it in at about 2k miles and this time they were willing to pull the valve cover and check. but, after they screwed up my oil change twice, I thought it best not to let them handle anything major, including pulling a valve cover.

wilsonville was much different. i had about 8k miles on it at this point, but still no CEL. I dropped it off at 8am, got a call at noon from enterprise asking me when i wanted to pick up my loaner (durango) before i even got in touch with the dealer.

they pulled the valve cover and had found found loose lifters. I had the jeep back 3 days later (due to waiting for parts and i also had the emergency brake replaced). I think the actual head repair took 1 day or less. so for T&C in wilsonville, it was 1 trip to drop it off, 1 to pick it up.

Wow that sounds like amazing service! I will keep that in mind if I ever need warranty work
Thanks for sharing


All times are GMT -5. The time now is 04:54 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.