Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   intermittant dash/gauges ???? 99 TJ (http://www.wranglerforum.com/f210/intermittant-dash-gauges-99-tj-200381.html)

Bucktaker 11-19-2012 11:03 AM

intermittant dash/gauges ???? 99 TJ
 
My new to me 99 TJ has a intermittant problem with the dash. Sometimes on startup the dash comes on as normal and goes thru its light check then I have no dash indicators and the airbag light is on. Once restarting the vehicle cured it then today it acted up and I drove it 10 miles to town to the parts store (rear diff seal) it never worked and I racked up no miles on the trip odo.
Got parts and started home the dash came on normally but while driving home I saw it flash off .....then came back on. where should I look for a loose or bad connection?

TexasTJ3016 11-19-2012 11:11 AM

Same problem on my 2000. Fixed it by removing the Instrument Cluster, cleaned the contacts and bent them slightly to make better connection.

TexasTJ3016 11-19-2012 11:14 AM

As a temporary quick fix/diagnostic tool, you can try emergency repair procedure #1. Give the top of the dash a solid wrap with your hand. If the dash works after that then see above.

Doublebarr 11-19-2012 11:16 AM

Quote:

Originally Posted by TexasTJ3016 (Post 3011474)
As a temporary quick fix/diagnostic tool, you can try emergency repair procedure #1. Give the top of the dash a solid wrap with your hand. If the dash works after that then see above.

LOLOL! This is EXACTLY what I did and it worked. So I got in there and did the quick clean and bend trick too :thumb:

Bucktaker 11-19-2012 07:43 PM

I forgot its a jeep thing lol...... just bang it

Ok where is the connector you are talking about? under the dash or behind the instruments cluster?

TexasTJ3016 11-19-2012 08:16 PM

Behind the instrument cluster. You will have to remove the instrument cluster to get to the connectors. Send me a PM with your email and I'll send you the directions.

bardb 11-20-2012 06:45 AM

TJ Jeep Problem with Instrument Guages.

Bucktaker 11-20-2012 10:41 AM

Quote:

Originally Posted by TexasTJ3016 (Post 3013103)
Behind the instrument cluster. You will have to remove the instrument cluster to get to the connectors. Send me a PM with your email and I'll send you the directions.


Thanks Tex... the link below your post has them included......seems easy enough

Might read over the led thread since Im pulling the cluster

Thanks again all this is a great resource.......:cool::cool:

Bucktaker 11-20-2012 10:42 AM

Quote:

Originally Posted by bardb (Post 3014283)


Thanks man thats what I needed...


All times are GMT -5. The time now is 07:19 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.