Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ General Discussion Forum (http://www.wranglerforum.com/f290/)
-   -   Please help 1991 Jeep Wrangler won't stay running (http://www.wranglerforum.com/f290/please-help-1991-jeep-wrangler-wont-stay-running-2007.html)

kingcarm 06-15-2006 05:36 PM

Please help 1991 Jeep Wrangler won't stay running
 
Hi all, I'm new here and a new owner of a 91 Jeep wrangler. Here's the problem. I just bought this vehicle and took it for a drive after purchasing it. After driving about 1/4 mile it stalled and would not start again. I turn the key, it runs for a few seconds and just stalls. I try giving it gas after start-up and it just stalls. Please help. Any input is greatly appreciated. Thanks all.

1BLKJP 06-15-2006 06:00 PM

Well to me it sounds like the Fuel Filter is clogged. On the YJ's they are located on the Driver Side frame rail right about where the back tire is. I think it's like a 20 dollar part also.

Did you buy this from a dealership?

kingcarm 06-15-2006 06:08 PM

No, private sale. It has 85K on it.

kingcarm 06-15-2006 06:33 PM

OK, I crawled under my jeep and have located the fuel filter. I see it has a clamp around it holding it in place and the clamp and fuel filter are rusted to shit so, I am going to change that. I also see that the air filter is also dirty as hell so I am changing that too. Anything else I can check that may be the problem???

amerijeep 06-15-2006 08:23 PM

Could be just about anything. I think we may need more info or what you have done so far.

CRISCO81 06-16-2006 12:09 PM

You may want to put some gas in it just to make sure it's not out. Mine ran out the other day and the guage showed it still had 3/8 of a tank.

bluvikng 06-16-2006 02:42 PM

I would also clean the heck out of the inside of the throttle body with some Berryman's carburetor cleaner, along with all the linkages on the outside. Check all of your vacuum hoses, as well.

And as CRISCO81 suggested, put some fresh gas in it. The fuel gage may not be working 100%.

kingcarm 06-16-2006 03:27 PM

Quote:

Originally Posted by CRISCO81
You may want to put some gas in it just to make sure it's not out. Mine ran out the other day and the guage showed it still had 3/8 of a tank.

Wow, I didn't think of that....if it were that simple, that would be great, I'm going to try that and I'll post after. Thanks.

amerijeep 06-16-2006 03:31 PM

Good luck, bro. I hope it is that easy for ya.

kingcarm 06-16-2006 04:00 PM

Quote:

Originally Posted by amerijeep
Good luck, bro. I hope it is that easy for ya.

Oh my God CRISCO81.....IT WORKED!!!!!!!!!! I just bought some gas and put it in and IT WORKED!!!!!!! I took it for a spin and no problems. Dude you are my GOD. A million THanks!!!!!

amerijeep 06-16-2006 04:04 PM

CRISCO81 gets the credit. He thought of it. CRISCO, you're the man.

Glad it worked for you.


All times are GMT -5. The time now is 08:05 AM.