Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Instr Panel lights - ground issue? (http://www.wranglerforum.com/f210/instr-panel-lights-ground-issue-200894.html)

theshers 11-21-2012 08:17 PM

Instr Panel lights - ground issue?
 
Removed dash to run some wires for new KC Hilites. Re-installed and all worked good. Sons pulled back off a couple times to replace a stereo and nw we have no dash lights. Blinkers and low gas lights work. Any suggestions?

BTW - have used this forum for years and never had to post. Wealth of information here. Thanks for all your posts.

theshers 11-21-2012 11:08 PM

Although I tested yesterday and lights worked, still unable to get the instrum panel to light up. Pulled off dash and reinstalled, pulled out stereo. If I pull the light switch partially out - just before parking lights turn on - I get dash lights. All the way out - no go. Thinking ground or bad rheostat.

Thoughts?

29JeepTJ09 11-21-2012 11:25 PM

My first guess would be a bad ground. Not totally sure about that though.

When I pulled my dash off a while back I accidentally turned the headlight switch to the right dimming my dash lights nearly all the way. In all the years of owning my Jeep I had never realized that it even had a way to dim the lights. :banghead: I spent days trying to figure out the problem only to find I twisted the dimmer down. Sorry don't mean to hijack just thought it was kinda funny.

theshers 11-22-2012 08:30 AM

Yep - tried that
 
Read through some posts and it seems you're not the only one to go through that :) Sort of like when I installed the KC Hilites and buttoned it up - one light didn't work. Helps if you connect all the quick connects ;)

I've found a good quality switch for under $20. I'll try that and post results. But if anyone else has any ideas - feel free to share.

theshers 11-22-2012 11:54 PM

Well heck
 
Good news, bad news....

After discovering that the rear running lights weren't working (front running and all blinkers worked - didn't think about checking rear running), my younger son could wait to research further and pulled the #1 fuse. It was fried. Replace the fuse and everything works. :dance:

Bad news? Well we pulled the dash back off and did all kinds of troubleshooting and online searching - only to find out it was a fuse! We had checked one fuse but not the one that counted! :doh:

Oh well - valuable lesson learned. And my son got the glory, so he goes to bed tonight with a feeling of accomplishment.


All times are GMT -5. The time now is 12:32 AM.