Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Radiator Question(s) (http://www.wranglerforum.com/f282/radiator-question-s-205682.html)

ZATJ 12-16-2012 05:01 AM

Radiator Question(s)
 
2 Attachment(s)
Hi, Decided to do a radiator flush this morning after noticing that the expansion tank do not retain any coolant despite filling up on numerous times during the last couple of months...no visible leaks and no sign of overheating according to the temperature gauge...
First question:
The radiator cap was replaced about 2 years ago, is it the correct one, 18lbs..

Also, at the bottom of the radiator there are 2 "valves" what will their purpose be? (Only one shown next to the drainplug- rubber cover removed)

Hammond_Egger 12-16-2012 05:21 AM

Quote:

Originally Posted by ZATJ (Post 3109210)
The radiator cap was replaced about 2 years ago, is it the correct one, 18lbs..

18lbs is correct.

Quote:

Originally Posted by ZATJ (Post 3109210)
Also, at the bottom of the radiator there are 2 "valves" what will their purpose be? (Only one shown next to the drainplug- rubber cover removed)

I am going to assume your Wrangler is a stick, correct?
The "valves" you are referring to are actually nipples... There is a cooler built into the radiator where the automatic transmission would connect to. These are not used with a standard shift transmission (My guess is that a previous owner replaced the radiatior (most non-OEM replacement radiators come with the cooler built in). You can ignore these connections.

If your Wrangler is an automatic, I would hope that there is an auxiliary cooler hooked up in place of using the radiator transmission cooler!

Shelby427 12-16-2012 05:33 AM

Howdy ZATJ welcome to the forum.

Yep right cap.

Those are the fittings for an automatic transmission cooler. It's built internal into the radiator. Guessing you have a standard transmission, and somewhere along the line the radiator was replaced with a "fits all" type. If so it's not used.

But if you have an automatic trans, hopefully it has a separate cooler added somewhere as the cooler is a must for any kind of life for your transmission.

Keep a close eye on the leak, you have one. If you have the 4.0 engine, some were known to crack the head between #3 and #4 cylinders. This will cause a small leak that you won't see on the outside. Pop the cap off the valve cover and look for any type of milky looking oil.

Other then that, could be something as simple as a tiny leak on the outside that evaporates quickly. Had one like that. The solder joint on the top bracket of the radiator had cracked. Tiny amount of coolant would leak out, but evaporate from the heat of the radiator. Only found it when I saw a stain on the side of the radiator.

Pressure tested it and there it was. Wasn't a bad fix, cleaned off the spot, and resoldered it.

Best of luck!

ZATJ 12-16-2012 05:44 AM

Thks Hammond, appreciated. Nope, the TJ is a "stick". Have also just added another 500ml of coolant after a short drive. Quite a relief to hear that the cap is correct one!:) Could not manage to undo the drainplug on the block, would seem that I will need to modify one of my existing Allen key, somewhere between 7 and 8mm? Sorry, this part of the woods everything is metric...

ZATJ 12-16-2012 06:35 AM

1 Attachment(s)
Thks Shelby, Did a bit of closer inspection and found that the gasket at the waterpump is being "pushed" out, also the gasket between the waterpump and block is very "brittle"...sorry the quality of the photograph is not very clear, don't worry about the brown, leftovers from last week's trip.
Would it be feasible just to replace the gasket...?


All times are GMT -5. The time now is 10:28 AM.