Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   battery/charging problem (http://www.wranglerforum.com/f210/battery-charging-problem-21138.html)

Warpman89 09-02-2008 02:25 PM

battery/charging problem
 
i left my lights on this morning and had to jump start it. now, when idleing, the rpm goes really low, an sometimes shuts off. i can only assume the battery is the original from 2004. what is the problem here? i need to drive to school everyday, should i replace my battery? along those lines, what is the general opinion of optima red top batteries? thanks

Atthehop 09-02-2008 09:11 PM

What does the volt meter read when it starts. It sounds like you alternator is not charging.

CVFD76 09-02-2008 09:37 PM

yea i would bet on the alternator. if it was ur battery once u jump started it it should run fine. to test wich one it is, jump it, if it stays runnin long enough, disconnect your neg battery connection, if the jeep still runs shitty or cuts off id put money on ur alternator. if it were the battery, once it was jumped, the volt meter would hold steady where it normally is, this is because the battery is only used to get the innitial power to the starter to turn the engine over, and of course little things like remote wires and stuff like that, but as far as the engine goes, once its started it runs off the alternator not the battery, also before you go buy a new alternator, check all your connections, and clean any corrosion/dirt/ and watever alse aint supposed to be there, iv had that problem b 4, some people would suggest putting... anyone know what that grease is called for electrical connections? anyways, some people would say put that on there, personally iv never seen where it made a difference.

slf41002 09-02-2008 10:06 PM

I wouldn't disconnect the battery cables to check the alternator due to the fact it is an 04 and doing so can spike the regulator and fry the computer.I would try another battery in it first from something else if possible because it sounds like it has a cell short in the battery also if you have a volt meter test the batt with the engine running if you can do so and it should read around 14 volts if the alt is charging if it is very far below that your alt is not charging.


All times are GMT -5. The time now is 12:35 PM.