Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   California Jeep Forum (http://www.wranglerforum.com/f55/)
-   -   TJ Clutch Problems, Please Help (http://www.wranglerforum.com/f55/tj-clutch-problems-please-help-21253.html)

Captmarkhd 09-06-2008 07:19 PM

TJ Clutch Problems, Please Help
 
Hey Guys,
So I broke my ankle about a year ago and I have not been able to use my jeep, she has sat for over a year in my garage. I went to drive it last night and I found that the clutch has no preasure, I checked the reservoir and it was empty, I filled it up with brake Fluid DOT 3, it came up on preasure but I still had no clutch, I could not get it into gear. So today I purchased a new master and slave cylander, installed both, bled the system by keeping the reservoir cap off of the master and slowly pumping the SLAVE cylinder, once I got a steady steam of fluid comming out of the top of the reservoir with no air bubbles, I bolted the slave back to the Transmission. Checked the clutch and still no go, it seems to have plenty of preasure,the slave seems to have allot of force with the piston but Still no clutch, I took it apart and bled it 3 more times with the same result. Am I missing somthing? The clutch was perfect when I parked it a year ago, no problems. Could somthing else be sticking in the clutch system because it sat, not allowing it to engage// Please Help Mark

Rawkon 09-11-2008 10:43 AM

sounds like its stuck, in my factory service manual it saaaay...

Normal condensation for vehicles stored for long periods of time can generate enough corrosion to make the disc stick to the flywheel or pressure plate. to fix it, manually loosen it through the inspection plate opening.

jdhallissey 09-14-2008 03:04 AM

Ok try this- put the jeep in the 4x4 neutral so the tranny is disengaged from the truck. Have a friend push it down the street and bump start it - the shock of the action may break it loose- may not but well worth a shot.

luckydusty 04-30-2013 09:30 PM

My clutch is doing the same thing, however mine hasn't sat for a length of time. It's my daily driver.
I was shifting gears and the clutch went to the floor. No pressure at all. Checked for leaks and fluid was dripping out of the slave cylinder.
Went to NAPA and bought a new slave cylinder.. Installed and bleed it..
Now the clutch is soft (no pressure) for 3/4 of the way down but the last 1/4 about breaks your leg.
Has anyone delt with this and what is the fix?

Indy 05-03-2013 01:10 PM

If it is soft .. then it still has air in it. Try bleeding it again. Sometimes an air bubble gets stuck due to the angle of slave cylinder. I had hard time bleeding it as well. I pressed the clutch really quick multiple times which did the trick for me.


All times are GMT -5. The time now is 07:30 PM.