Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Electrical Endeavors (http://www.wranglerforum.com/f218/electrical-endeavors-213284.html)

Normus 01-18-2013 08:51 PM

Electrical Endeavors
 
My jeep has been on the road for some time now. I have never had any performance issues at all until the other day when the battery charge indicator gauge began fluctuating. While doing so, my headlights would dim, and the engine would sputter as though it was running out of gas. I limped it about four miles, before quite suddenly, everything returned to normal and I was able to race along home. I was gonna chalk it up to a bad alternator, or maybe a tired battery. But it's sudden recovery has me thinking it could be a wiring issue. I haven't tinkered with the wiring in a long time, so I can't quite place what the issue really is. Can anyone help me understand whats going on here?

Thanks.

90YJinPC 01-18-2013 11:19 PM

auto zone or advance will do a free charging system check. could b a possible ground problem.

KIDDtastrophe 01-18-2013 11:54 PM

Check your main grounds. Battery to block, block to firewall, block to frame. My block to firewall was hanging by a few threads and acted the same way.

Normus 01-22-2013 08:21 PM

It turned out to be a worn spark plug cable. Simple fix. I used it as a chance to replace all of the spark plugs and cables. Even put in a new battery. Runs like a top again. Odysseus rides again!

KIDDtastrophe 01-22-2013 10:41 PM

Wow craziness haven't heard that one before ill put it in the ole storage bank. Glad to hear it up and going again. Good job.

Normus 01-24-2013 05:32 PM

Yeah, it kept grounding out the entire electrical system. Once I saw the cable I was like "Yep, makes sense." I guess the P.O. never, ever changed the cables or plugs.


All times are GMT -5. The time now is 11:57 PM.