Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Engine code help (http://www.wranglerforum.com/f210/engine-code-help-216634.html)

Tjrubicon17 02-02-2013 09:33 PM

Engine code help
 
Last week I just replaced the 2 upstream O2 sensors. Engine light is putting out the following codes:
P0122- Tps apps low voltage
P0135- O2 sensor heater failure
P0139- O2 sensor slow response
P0138- O2 sensor shorted to voltage
I don't know very much about engine codes. I'm assuming these codes are coming from the down stream O2 sensors? Is that safe to assume. I'm kind of nervous about the upstream O2s because I bought the Bosch sensors by accident/ out of ignorance. Also there is the TPS/ APPS code... Do I need to replace this also? Thanks for the help in advance.

Tjrubicon17 02-02-2013 09:39 PM

By the way...It's an 03 rubicon 4.0l with 108k on the odometer.

Gixxer86g 02-03-2013 07:04 AM

135 is the upstream. 138 and 139 are the downstream.

Tjrubicon17 02-03-2013 08:37 AM

Thanks. Do you think it's possible that the upstream has gone bad already? Or maybe the code just hasn't reset from the old sensors?

Neil F. 02-03-2013 10:29 AM

If a problem fixed the code will clear right away.

Did you use Bosh O2s? If so that is the problem. The Chrysler PCM does not like them.

bobjenkins 02-03-2013 10:32 AM

Mine is throwing the same code occasionally . 03 Rubi with Bosch sensor

Tjrubicon17 02-03-2013 11:55 AM

Yes I did use the Bosch O2 sensors. Autozone ripped me off for them too.

jkp 02-03-2013 12:55 PM

Disconnect the battery to reset the codes and see if they come back.

Best bet for the O2s are the OE NTKs made by NGK.

Neil F. 02-03-2013 01:04 PM

Get ntk sensors. Do a search on bosch and you will see that they just willnnot work with the jeep. Been there done it .

Gixxer86g 02-03-2013 01:48 PM

I'm partial to Nippon Denso. NTK is good. Anything but Bosch.

Tjrubicon17 02-03-2013 02:07 PM

Has anyone had any luck with returning parts to autozone?

Gixxer86g 02-03-2013 02:20 PM

Quote:

Originally Posted by Tjrubicon17 (Post 3315959)
Has anyone had any luck with returning parts to autozone?

Don't know. I work at a REAL parts store, and Autozone buys from me all the time. And they return most of what they get. Autozone sucks in every way. Consider it a lesson learned.

Neil F. 02-04-2013 06:25 AM

Quote:

Originally Posted by Tjrubicon17 (Post 3315959)
Has anyone had any luck with returning parts to autozone?


Very unlikely that they will take back used O2 sensors.

Tjrubicon17 02-04-2013 06:43 AM

I'm going to try. I still have the boxes and receipts. For 110 bucks it's worth a shot.

bobjenkins 02-07-2013 07:38 PM

I returned a used sensor to auto zone no prob


All times are GMT -5. The time now is 11:49 PM.