Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Speedo And Odometre (http://www.wranglerforum.com/f210/speedo-and-odometre-217795.html)

styxer 02-07-2013 04:52 PM

Speedo And Odometre
 
Hi Jeepers!

First off, I'm new to the forum's, and apologise in advance if this is not the place to write up for some assistance with my problem, so if this is the wrong place, I'm happy to put the thread elsewhere :)

Now to the problem, and what i've attempted so far to resolve.

Speedo and Odometre stopped working

Symptoms,

Rough Idle
Stalls at lights or when braking at stop signs etc (Have found tapping the accelerator stops this problem before coming to a stop)
Speedo does not work nor does the Odometre
Water pump has begun making strange noises(I believe this is an alternate problem)

Strangely, 2 weeks after it occured, driving home the whole system began working correctly, the speedo was working fine, while being a little jumpy, the odometre began recording additional kilometres, then when I turned off the jeep at home, it stopped working again. :doh:

What i've tried,

I've pulled the cluster out, cleaned the pin's and twisted them 10 degrees to attempt a better contact (Will be purchasing dielectric grease this weekend for round 2).

Pulled the Speed Sensor out from the transfer case, cleaned up the unit, checked the pinion and that it is not stripped, i've traced the wiring and it seems fine.

The gear ratio is correct as well, as it has stock wheels currently, and I've made sure it is in the right position and lines up with the little dot on the Tcase.


Anyhow, I don't want to take it back to the dealership, they charged me $770 to tell me the speedo needs changing (the reason I took it to them in the first place!! :banghead: ) but they did give me the code P0500 so hopefully that helps.

If you could list your suggestions, I'd greatly appreciate all assistance and thanks in advance!!

Styxer

Clemson 02-07-2013 07:35 PM

Styxer. The dealer is probably right with replacing speedo head. Not a difficult job and the parts are cheap.

mudmagnet63 02-07-2013 07:40 PM

Is your tach doing the same thing? Mine does this on occasion spedo & tach drop to zero for a while, then jump to normal. I can't find any reason these things are happening.


All times are GMT -5. The time now is 05:02 PM.