Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Fog lights quit working (http://www.wranglerforum.com/f210/fog-lights-quit-working-219512.html)

mygirlscallhim pedro 02-14-2013 09:01 PM

Fog lights quit working
 
Install new KC fog lights last night everything worked fine. Washed salt off at car wash and lights worked after that. Stopped in town and on way home went to turn them on and nothing. Everything checks out ok? Any thought? Relay go bad?

Evpjr 02-14-2013 09:31 PM

Jumper around the relay and see.

mygirlscallhim pedro 02-14-2013 09:33 PM

Jump around relay?

XwXCHADWICKYXwX 02-14-2013 10:21 PM

Possibly blew a fuse. Check the fuses on the wire that leads to the lights. Pretty basic but can be forgotten. In my case the entire wire fried but I never use them so I haven't done anything about it yet.

XwXCHADWICKYXwX 02-14-2013 10:22 PM

I have the KC`s as well

Brew 02-15-2013 01:18 AM

Maybe a short from the water? How well did you weatherproof the wiring?

mygirlscallhim pedro 02-15-2013 06:40 AM

Everything was dry with the exception of the connections at the lights. Should I wrap that connection with elec. tape? I mounted the relay high on the firewall.

mygirlscallhim pedro 02-15-2013 06:45 AM

Yes first thing I check were fuses.

mygirlscallhim pedro 02-15-2013 05:40 PM

Thank you to everyone who replied. After buying a volt meter for $25 it was something simple that was wrong. I mount my relay and ground with the same screw on the firewall. screw must have lost contact with wire and since the firewall is painted... No Ground...


All times are GMT -5. The time now is 10:44 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.