Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   strange smell while driving. (http://www.wranglerforum.com/f210/strange-smell-while-driving-219618.html)

ninjaturtle0 02-15-2013 12:22 PM

strange smell while driving.
 
it has happen to me twice so far..

I'm stuck in traffic and there is this strong smell and at first I thought it was another car but it happened this morning.

when I had my car before in the past I accidently drove with the emergency brake on and when I noticed it and stopped it had this same smell so I'm thinking it has something to do with my brakes??? but this rarely happens

Thinking of getting my brakes checked this weekend.

G.A. Heath 02-15-2013 12:26 PM

If your transmission is a standard it could also be your clutch.

NCJeepin 02-15-2013 12:30 PM

Did you happen to eat Taco Bell beforehand?

ninjaturtle0 02-15-2013 12:42 PM

lmao at Taco Bell

I have Auto transmission, had a flush about 6 months ago so fresh fluid

Tjrubicon17 02-15-2013 01:28 PM

Happened to me last week. Turned out my the circuitboard behind my gadge cluster shorted out now the lights behind my gadges don't work.

ninjaturtle0 02-15-2013 02:28 PM

Quote:

Originally Posted by Tjrubicon17 (Post 3372681)
Happened to me last week. Turned out my the circuitboard behind my gadge cluster shorted out now the lights behind my gadges don't work.

my dash lights still work... I hope something serious doesn't happen!

Jeep runs fine

PStov98TJ 02-15-2013 02:32 PM

You could be dragging a brake pad. Like one is just slightly touching the drum or disk. Enough to heat it up but not enough to slow the jeep down.

ninjaturtle0 02-15-2013 04:08 PM

Quote:

Originally Posted by PStov98TJ (Post 3372930)
You could be dragging a brake pad. Like one is just slightly touching the drum or disk. Enough to heat it up but not enough to slow the jeep down.

taking my Jeep to have the brakes checked this weekend

PStov98TJ 02-15-2013 04:17 PM

If its not brakes it maybe something within the transmission. Good luck. Keep
Us posted here. We might be able to help out.


All times are GMT -5. The time now is 01:36 PM.