Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK General Discussion Forum (http://www.wranglerforum.com/f274/)
-   -   Help engin check light (http://www.wranglerforum.com/f274/help-engin-check-light-220190.html)

Jared66 02-17-2013 09:29 PM

Help engin check light
 
Sooo 2011 jkur. Was going over a log perpendicular to my jeep. Logs on either side to drive up and down. And one slid out. High centering me. Hooked up my winch. And dragged myself over. The logg rolled under as I rolled over. Tore the front boot off the front drive shaft. And then. A minute down the road the check engine light came on. Iv crawled under and can't find a damn thing anywhere. Stock jkur. Other then sliders front bumper and cai and cat back exhaust. Any ideas? I don't have a programmer to check the code.. No word rattles or anything. Everything drives normal.

Rtone1583 02-17-2013 09:55 PM

Here you go. Jeep Parts, Jeep Accessories & Jeep Soft Tops From The Jeep Parts Experts - Quadratec

One thing I have found is that the various sensors on the JK's are sensitive enough to set a code on the most minor and intermittent of issues (the system will basically set a code on a simple hiccup) so don't drive yourself crazy trying to diagnose what my be wrong.

I've had numerous codes set while out on the trail and the best way I've dealt with it is to pull the code and clear it by disconnecting the battery for a few minutes and research the code to find any information you can. In the meantime, drive it like you normally do (on and off road) to see if the code resets. More often than not, the code won't reset.

joe002 02-17-2013 10:52 PM

Iíve never tried it myself, but:

Insert your key into the ignition, turn it to the on position but do not start the engine. Push the key into the ignition cylinder and while holding it in, turn it to the off position and then back to the on position times making sure to end with it in the on position. Your dash lights should come on and your odometer will show six dashes. Your codes will display after the dashes.

You may want to check to see if you hit your evaporative canister/cabling with the log.

SilverSport 02-17-2013 11:16 PM

Quote:

Originally Posted by joe002 (Post 3382782)
........You may want to check to see if you hit your evaporative canister/cabling with the log.

^This.

ko26 02-17-2013 11:26 PM

Not sure where you're located but there are probably shops in your area that will run a diagnostic test for you for free. I'm pretty sure AAMCO does it as well as other locations.

Jared66 02-17-2013 11:57 PM

Thank you. I figured there would be a cheat code to access them.

Jared66 02-18-2013 08:32 AM

Tried the ignition thing. Didn seem to work

joe002 02-18-2013 09:35 AM

Quote:

Originally Posted by Jared66 (Post 3384194)
Tried the ignition thing. Didn seem to work

Oops, sorry. Like I said I haven't tried it myself, but in the instructions I left out the word "three" - you need to do the on/off thing three times.

Jared66 02-18-2013 11:57 AM

Yeh tried 2 3. And 4. Didn't work. Although one of them cleared ye light off lol

joe002 02-18-2013 02:56 PM

Quote:

Originally Posted by Jared66 (Post 3384994)
Yeh tried 2 3. And 4. Didn't work. Although one of them cleared ye light off lol

Ha, I guess you fixed it then! ;)

Rtone1583 02-18-2013 09:18 PM

Codes/lights will clear after a certain number of "good" ignition cycles. This doesn't mean that the problem has gone away entirely, only that the same problem didn't happen again within a certain number of ignition cycles from when the code was originally set. Of course this doesn't mean that the original code was an actual problem either. It could have been as simple as a hiccup in the system.


All times are GMT -5. The time now is 03:04 PM.