Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Clicking after wet interier (http://www.wranglerforum.com/f210/clicking-after-wet-interier-2211.html)

Wr@ngler00 07-07-2006 01:19 AM

Clicking after wet interier
 
Tonight i had the top down in my jeep. My interier got wet but not soaked. When i started it up i noticed a sound coming from my steering column. Sounds like my blinker is on but it is a very fast paced (click-click). Heres the kicker, my blinkers are not flashing and when i tap or hold my brake pedal the clicking stops. As soon as i take my foot off the pedal it starts again. Also when i put my blinker on the clicking slows down to the match the pace of the flashing green arrow. I pulled my indicator fuse buhind my glovebox and the clicking stops but so does all functioning of my blinkers/hazards. I put the fuse back in and the clicking starts again. What could this be??????

Jerry Bransford 07-07-2006 01:27 AM

Relax, this happens when that area gets wet and it'll go away after it's had time to dry out.

Wr@ngler00 07-07-2006 01:34 AM

Have you had this happen to you before? I appreciate your response, i was worried that i had shorted something out and was gonna have to take it to the stealership!!

mmasuperman12 07-07-2006 07:27 AM

i had the same thing in my YJ drives me nuts but it always goes away after a few dry days.

jbone303 07-08-2006 01:39 PM

i get stuck in the rain bout once a month and i have that clicker about once a month for bout a day. so just let dry out and it will be fine

compshooter 07-10-2006 10:37 AM

I disagree with the "let it dry out and it will be fine" theory. Mine does that also, but only on left hand turns, and not all the time. Stepping on the brakes will make it stop and when I release the brakes, it starts blinking again rapidly.

I live in 29 Palms, which is a high desert and we get very little rain a year, and summer temps easily over 100 degrees. I think it's pretty dry if it ever got wet.

This is a known problems with TJ's (and Cherokees since they use the same assembely). The part you are refering to is known as the "multi-function switch" which is your blinkers and high/low beam selector. They go bad, don't know why. I know of no fix other than replacing it. I replaced mine (off Ebay, $16) and works OK. Still have the problem, though way less than I did before.

One trick is once it starts blinking rapidly, pull back slightly on the stalk (like you're going to flash the high beams). This will make it go to normal speed.

Hope this helps. Keep us posted on your results. Hopefully yours is the rare case where it dries out and is fine.

Wr@ngler00 07-10-2006 03:24 PM

Thanks for all the tips guys. I went to check my jep today and the problem had ceased. This is a wierd issue but obviously not uncommon. Thanks again.....


All times are GMT -5. The time now is 01:12 AM.