Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   Help! Floor lights and radio stopped working! (http://www.wranglerforum.com/f210/help-floor-lights-and-radio-stopped-working-221186.html)

chrislewis 02-21-2013 08:03 PM

Help! Floor lights and radio stopped working!
 
So I'm hooking up a subwoofer in my TJ. All was going well until we went to push the head unit back in. The top of the head unit made a small spark, then the radio and floor lights stopped working. I have no idea what the hell happened. I checked all of the fuses behind the glovebox and they were all good. I'm officially stumped. Please save me from this silent torture.

(no power to radio, no power to lights, checked the fuses)

2000jk 02-21-2013 08:09 PM

Quote:

Originally Posted by chrislewis (Post 3402200)
So I'm hooking up a subwoofer in my TJ. All was going well until we went to push the head unit back in. The top of the head unit made a small spark, then the radio and floor lights stopped working. I have no idea what the hell happened. I checked all of the fuses behind the glovebox and they were all good. I'm officially stumped. Please save me from this silent torture.

(no power to radio, no power to lights, checked the fuses)

I have the same problem

jeepers29 02-21-2013 08:11 PM

There are some fuses under the hood as well.

chrislewis 02-21-2013 08:13 PM

Do you know what fuse to check? I'm fighting an ice/snow storm outside and am running in and out to warm up. lol

2000jk 02-21-2013 08:15 PM

Jk bump

chrislewis 02-21-2013 08:32 PM

Bump. Sorry I'm desperate and need it fixed asap

tbensor 02-21-2013 08:36 PM

Fuse #15 10amp fuse. It should be located in the fuse block behind the glove box. Did you meter it? I would replace it.

tbensor 02-21-2013 08:38 PM

this assumes someone didn't hot wire it. Are you the original owner? Can you tell if is using the original harness

chrislewis 02-21-2013 08:42 PM

I am not the original and it looks like a new harness on the radio

tbensor 02-21-2013 08:59 PM

hmm. is the harness connected to stock wires

chrislewis 02-21-2013 09:26 PM

I found it! I pulled all of the fuses under the hood and it was the last one. Sorry about the dumb amateur sounding post. But the wiring of the radio was terrible and I thought it had a lot to do with that. Thanks for the help and motivation to get my ass back out in this blizzard!

tbensor 02-21-2013 09:55 PM

awesome

2000jk 02-21-2013 11:01 PM

Bump

RUBI 4 MY MRS 02-22-2013 02:11 AM

On the 2000 the fuse is #25 in the PDC in front of the battery.


All times are GMT -5. The time now is 06:32 PM.