Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   Communications and Electronics (http://www.wranglerforum.com/f40/)
-   -   Radio install problem--No sound (http://www.wranglerforum.com/f40/radio-install-problem-no-sound-224903.html)

1997 03-03-2013 03:52 PM

Radio install problem--No sound
 
I installed a Kenwood KDU 252 from Best Buy yesterday in my 1997 TJ.
Tested it and it worked.

Today I go to finish the install and disconnect the harness, but this time I didn't disconnect the battery negative.

I get the kit and cage installed and plug everything back in.
Power comes on, it functions-but no sound.

I checked the connections 5-6 times.
Check the fuse behind the glovebox and at the back of the radio-both 10 amps and both fine.

I checked through the audio menus and tried to make changes, still no music, no static, no noise whatsoever.

Help:surrender:

jp2611 03-03-2013 03:54 PM

Power surge reset button somewhere? I am guessing....probably on the radio...if not IMO best guess you might be starting over!!

1997 03-03-2013 04:00 PM

Quote:

Originally Posted by jp2611 (Post 3449175)
Power surge reset button somewhere? I am guessing....probably on the radio...if not IMO best guess you might be starting over!!

Yeah I held a pen in the reset and after a few second the cd players started running

1997 03-06-2013 04:47 PM

bump for more help...

eboven 03-06-2013 06:36 PM

I would put money on a speaker grounding out. First, check behind the radio - make sure none of the wires got pinched or cut. If you have aftermarket speakers than also pull each of those to ensure the connections aren't touching metal or pinched anywhere. If everything looks fine, you can do an easy test with a multi-meter. Disconnect the stereo harness and set your meter to continuity. Place the black probe on a ground source and use the red probe to hit each speaker wire individually. If any of them show continuity to ground you may have bad wiring or a blown speaker.

Aftermarket decks will set their amp into protect mode when a speaker lead grounds out - your original stereo did not have a protect circuit, so it would just keep playing at high distortion if it had a grounded speaker.


All times are GMT -5. The time now is 03:51 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.