Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Jeep rattles when accelerating! Any Ideas? (http://www.wranglerforum.com/f218/jeep-rattles-when-accelerating-any-ideas-226140.html)

KCHITT89 03-08-2013 09:46 AM

Jeep rattles when accelerating! Any Ideas?
 
So I bought my first Jeep a month ago, 89 Wrangler, and have done a few minor and basic repairs but I don't know how to fix this one. When I press the gas pedal pretty hard, I get a loud rattling sound which (seems like it anyway) is coming from the front passenger side. It doesn't do it when I accelerate gently but when I'm trying to go up a hill on the highway, I gotta push the gas a little if I want to keep it above 45 mph! I am NOT a mechanic, but I love to mess with stuff under the hood and do my best to figure it out on my own so if anybody has any ideas where I should start, I'll take 'em and start weeding out possibilities. Thanks!

STEVE 0 03-08-2013 10:05 AM

Hard to say without seeing a video or something. But are all your exhaust hangers good? Maybe the cat?

GooKZiLLA 03-08-2013 11:48 AM

I had a rattle in the front passenger side a few weeks ago. I was missing a bolt in my starter. Went down to Ace hardware and picked up a matching size, popped it in. No more rattle. That's always something you can check.

peety 03-08-2013 12:03 PM

Check for an exhaust leak at the manifold/down pipe connection

Garyk 03-08-2013 12:24 PM

Could be piston knock from low grade fuel or timing....

khende 03-08-2013 01:33 PM

How many miles are on the motor and has it been rebuilt? My 89 has about 225k miles on it when I bought and the PO said it had been rebuilt once. The bottom end was rattling on acceleration. I just replaced the motor. (cracked head) If it is the bottom end it can be driven. My brother in law has the same issue and plans on driving it until it breaks. If this is the issue the motor will need to be replaced or rebuilt sooner than later.

YJ360 03-08-2013 05:00 PM

Man I have the same problem In my 94 wrangler I originally thought it was the dust shield on the brakes but I crossed that one off try the dust shield on you front drive shaft yoke?

Garyk 03-09-2013 12:04 PM

Probably not but check the CAT....

KCHITT89 03-10-2013 08:33 AM

I spent all day yesterday replacing original carb with a motorcraft kit from the eBay guy. Also did nutter bypass and yanked out every piece of unnecessary vacuum line I felt safe taking out. Drove it home from the garage, 30 miles of interstate, 70 mph all the way. No rattle! I don't know if it was a fluke or if I removed something that went to whatever the culprit was but for now, I'll take it. Thanks everyone for your input!

SoILJeepGuy 04-13-2013 11:34 AM

I have the same problem with my 94 Yj, i've been trying to figure it out myself.. i was missing a bolt in my dust pan and thought it was that, but it didn't solve the problem..... i can only assume it is the exhaust mount or the CAT, I'm hoping to get out to the garage this weekend and see if i can pin-point the noise... if I do , I'll repost and let you know what fixed mine (IF I GET IT FIXED) !!!! GOTTA LOVE OUR YJ's !!


All times are GMT -5. The time now is 10:04 AM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.