Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   1995 YJ grounds... (http://www.wranglerforum.com/f218/1995-yj-grounds-226893.html)

TonyGreen 03-11-2013 05:22 PM

1995 YJ grounds...
 
Hey Everybody!!

My wrangler: 1995 YJ 2.5L 5 Speed

I was wondering which are the grounds that have anything to do with starting the car? As some of you might know, I still haven't been able to start my car. I have checked two grounds the battery ground and the starter/frame ground.

I was told that there are 6, is that true? Also where are they located?

I did research around but have not found a definite answer.

Thanks

Garyk 03-11-2013 05:34 PM

I think the rest are frame to body. There might be one from the firewall too. If you have a good ground at the engine and at the frame the starter should spin

TonyGreen 03-11-2013 07:27 PM

alright, thanks. The starter does crank (turn over). Its just that the engine does not start. I think it is a ground cable.

Thanks for the feedback...

rebelBullDawg325 03-11-2013 08:50 PM

should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system

TonyGreen 03-11-2013 09:04 PM

Re: grounds
 
Quote:

Originally Posted by rebelBullDawg325 (Post 3490840)
should be a ground that attaches to the bracket for the e-brake pedal. i think it is for the fuel pump or something in the fuel system

Thank you! I will check that.. at this point anything is game.

TonyGreen 03-12-2013 08:41 PM

My problem was definately electrical most likely PCM. The car is running now after following ambushtom's advice on his thread "YJ dies... PCM and Grounding issue" it could also be the fact that I cleaned the fuses and relays in the engine compartment and also the ones underneath the steering wheel.

Thanks


All times are GMT -5. The time now is 10:58 AM.